Bug 35257 - Xamarin Forms - Breaks build - Android Resources missing
Summary: Xamarin Forms - Breaks build - Android Resources missing
Status: RESOLVED DUPLICATE of bug 35074
Alias: None
Product: Forms
Classification: Xamarin
Component: Forms ()
Version: 1.5.0
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Bugzilla
Depends on:
Reported: 2015-10-26 11:04 UTC by David Strickland
Modified: 2016-04-13 19:15 UTC (History)
6 users (show)

Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description David Strickland 2015-10-26 11:04:49 UTC
See: https://bugzilla.xamarin.com/show_bug.cgi?id=35074#c1

Functional code base. on

Issue Nuget Update Packages

Application will no longer build. full error and build log in Comment 1 of #35074

Code base available @ https://github.com/Indiponics/IndiXam-Lib
Comment 1 David Strickland 2015-10-26 11:24:14 UTC
In summary the build breaks with


"C:\Program Files (x86)\Jenkins\jobs\IndiXam\workspace\Jenkins\BuildScript.MSBuild" (default target) (1) ->
"C:\Program Files (x86)\Jenkins\jobs\IndiXam\workspace\Projects\GestureRecognizers.Droid\GestureRecognizers.Droid.csproj" (default target) (3) ->
(_UpdateAndroidResgen target) -> 
  C:\Program Files (x86)\Jenkins\jobs\IndiXam\workspace\Projects\GestureRecognizers.Droid\obj\Debug\resourcecache\07DB0F3FBE12E22E40A1BC5F32FC1890\res\values-v23\values-v23.xml(6): error APT0000: Error retrieving parent for item: No resource found that matches the given name 'android:TextAppearance.Material.Widget.Button.Inverse'. [C:\Program Files (x86)\Jenkins\jobs\IndiXam\workspace\Projects\GestureRecognizers.Droid\GestureRecognizers.Droid.csproj]
  C:\Program Files (x86)\Jenkins\jobs\IndiXam\workspace\Projects\GestureRecognizers.Droid\obj\Debug\resourcecache\07DB0F3FBE12E22E40A1BC5F32FC1890\res\values-v23\values-v23.xml(25): error APT0000: Error retrieving parent for item: No resource found that matches the given name 'android:Widget.Material.Button.Colored'. [C:\Program Files (x86)\Jenkins\jobs\IndiXam\workspace\Projects\GestureRecognizers.Droid\GestureRecognizers.Droid.csproj]
Comment 2 Paul DiPietro [MSFT] 2015-10-26 17:27:06 UTC
I just pulled the repo and updated Forms to, and it seems to build correctly. Have you tried using this version and building since?
Comment 3 David Strickland 2015-10-26 18:37:00 UTC
Yes just tried again to check same onslaught of errors. 

However if its building for you then its obviously something with my box. 
I already wiped out the AppData\Xamarin\Xamarain* folders and forced them to reload but that didnt help.

I'll see if I can pound it out. I'll update here if I get anywhere.
However any suggestions would be appreciated.
Comment 4 David Strickland 2015-10-26 19:18:07 UTC
The codebase appears to be irrelevant to the reproduction of the error.

If I create a new Android Project in Xamarin Studio and build it it's fine but as soon as I update Nuget Packages I get the same errors on an empty codebase that I was receiving for my Github codebase.
Comment 5 David Strickland 2015-10-27 03:34:27 UTC
Xamarin Forms adds a dependency to 

These appear to depend on Android SDK Platform 23.1 which I did not have installed. Installing Android 6 - SDK Platform made it possible to compile.

Note my application was set to target Kit Kat(4.4 API 19) having to install API 23 to get my API 19 App to build seems none intuitive and prone to cause others the same issue. 

I consider having to diagnose all this and install API 23 a work around and as such left the ticket open. 

A fix would be to at a minimum to inform the user that API 23 is required. 
A better solution would be to incorporate it into Xamarin Studio so when Android releases a new SDK (that Xamarin supports) the IDE informs you and gives you the option to update it. 
Best option would be not to require API 23 when the target is API 21 but I accept that that solution may be beyond what is economically feasible.
Comment 7 Samantha Houts [MSFT] 2016-04-13 19:15:55 UTC

*** This bug has been marked as a duplicate of bug 35074 ***