Bug 34995 - Debug Options available when in release/appstore/adhoc configuration
Summary: Debug Options available when in release/appstore/adhoc configuration
Status: VERIFIED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: iOS add-in ()
Version: 5.10 (C6SR3)
Hardware: Macintosh Mac OS
: High major
Target Milestone: 5.10 (C6)
Assignee: Jeffrey Stedfast
URL:
Depends on:
Blocks:
 
Reported: 2015-10-16 18:36 UTC by James Montemagno [MSFT]
Modified: 2015-10-27 03:44 UTC (History)
4 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Pasted image at 2015_10_16 02_33 PM.png (32.75 KB, image/png)
2015-10-16 18:36 UTC, James Montemagno [MSFT]
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description James Montemagno [MSFT] 2015-10-16 18:36:18 UTC
Created attachment 13408 [details]
Pasted image at 2015_10_16 02_33 PM.png

# Steps to reproduce
1.) Set iOS app to appstore/adhoc configuration

# Expected behavior
Only valid settings should be checkable

# Actual behavior
Device specific and incremental builds are available.

# Supplemental info (logs, images, videos)


# Test environment (full version information)
			  === Xamarin Studio ===

Version 5.10 (build 811)
Installation UUID: f081c568-2d88-4695-ac20-73049973693d
Runtime:
	Mono 4.2.1 (explicit/804ddbc)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 402010060

=== Xamarin.Profiler ===

Version: 0.0.0.0
Location: /Applications/profiler-mac-0.9-29/XamarinProfiler.Mac.app/Contents/MacOS/XamarinProfiler.Mac

=== Apple Developer Tools ===

Xcode 7.0.1 (8228)
Build 7A1001

=== Xamarin.iOS ===

Version: 9.2.0.84 (Business Edition)
Hash: b5396c2
Branch: master
Build date: 2015-09-30 15:22:15-0400

=== Xamarin.Android ===

Version: 6.0.0.8 (Business Edition)
Android SDK: /Users/jamesmontemagno/Library/Developer/Xamarin/android-sdk-mac_x86
	Supported Android versions:
		2.3   (API level 10)
		4.0.3 (API level 15)
		4.3   (API level 18)
		5.0   (API level 21)
		5.1   (API level 22)
		6.0   (API level 23)

SDK Tools Version: 24.4
SDK Platform Tools Version: 23.0.1
SDK Build Tools Version: 23.0.1

Java SDK: /usr
java version "1.7.0_75"
Java(TM) SE Runtime Environment (build 1.7.0_75-b13)
Java HotSpot(TM) 64-Bit Server VM (build 24.75-b04, mixed mode)

=== Xamarin Android Player ===

Version: 0.6.2
Location: /Applications/Xamarin Android Player.app

=== Xamarin.Mac ===

Version: 2.4.0.79 (Business Edition)

=== Build Information ===

Release ID: 510000811
Git revision: 34cd31ea72536afab530c14d9220b286075e83cd
Build date: 2015-09-30 10:40:37-04
Xamarin addins: 8e6fccfc0c19a7e0b7b11be925f09751d827eb5c
Build lane: monodevelop-lion-cycle6

=== Operating System ===

Mac OS X 10.10.5
Darwin Jamess-MacBook-Pro-2.local 14.5.0 Darwin Kernel Version 14.5.0
    Wed Jul 29 02:26:53 PDT 2015
    root:xnu-2782.40.9~1/RELEASE_X86_64 x86_64
Comment 1 Danish Akhtar 2015-10-19 06:17:59 UTC
I have checked this issue with builds mentioned in bug description and getting the same issue. We are getting Enable Debug Options available in release/appstore/adhoc configuration.

Screencast for the same: http://www.screencast.com/t/7PTa421Pg

ide logs: https://gist.github.com/saurabh360/0409756422ebcf50b86d

Hence marking this as Confirmed.

Regression status: We are not getting Enable debugging option in Release, Adhoc and Appstore mode in XS 5.9.7(build 22) + X.IOS 9.0.1.29
Comment 3 Jeffrey Stedfast 2015-10-19 12:54:08 UTC
Why should they not be available? Because of the name of the configuration?
Comment 4 James Montemagno [MSFT] 2015-10-19 13:30:52 UTC
I don't think they should be there because of the type of build. Other options get grayed out when you are going into release/adhoc/appstore mode.
Comment 5 Jeffrey Stedfast 2015-10-19 13:38:21 UTC
They do? If they do, that is a bug.

These options being available or not available should not be based on the arbitrary string names of the configuration name.

What is your goal of adding these restrictions?
Comment 6 James Montemagno [MSFT] 2015-10-19 13:44:52 UTC
This is my fault I thought that VS and XS had disabled things in the past based on these. Via this discussion with Mr. Stedfast this should be marked as not a bug.
Comment 7 Jeffrey Stedfast 2015-10-19 13:46:37 UTC
ok
Comment 8 Prashant manu 2015-10-27 03:44:04 UTC
as Per comment 6 closing this issue.