Bug 3499 - Hovering over a variable in the debugger gives a popup in the upper left corner of MD
Summary: Hovering over a variable in the debugger gives a popup in the upper left corn...
Status: RESOLVED DUPLICATE of bug 3556
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Debugger ()
Version: Trunk
Hardware: PC Linux
: --- normal
Target Milestone: ---
Assignee: Jeffrey Stedfast
Depends on:
Reported: 2012-02-16 12:56 UTC by David Ferguson
Modified: 2012-02-21 12:38 UTC (History)
1 user (show)

Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description David Ferguson 2012-02-16 12:56:08 UTC
Description of Problem:

Hovering over a variable in the debugger gives a popup in the upper left corner of MD

Steps to reproduce the problem:
1. Run application with a breakpoint in code
2. Hover over a variable in the debugger.  In my case I've seen this with both class level and local scope variables

Actual Results:

The popup with the variable info appears at the upper left hand corner of MD.

Expected Results:

The popup should be at or near the mouse coordinates.

How often does this happen? 

Every time I debug

Additional Information:

I'm running Ubuntu in a VirtualBox install on Windows 7.
Comment 1 Jeffrey Stedfast 2012-02-16 15:12:46 UTC
This is in all likelyhood a bug in Ubuntu. Works fine everywhere else.
Comment 2 Jeffrey Stedfast 2012-02-16 15:21:37 UTC
what version of MonoDevelop are you using? What version of Mono? What version of Ubuntu?

I can't reproduce this with Mono 2.10.9, MonoDevelop 2.8.7, on Ubuntu 11.10
Comment 3 Jeffrey Stedfast 2012-02-17 08:37:49 UTC
I was able to reproduce this on Ubuntu 11.10, but it only happened once. The next time I hovered over the exact same variable, it showed up where it should have. Haven't been able to reproduce since.

I can't repro on OpenSUSE so far.

I suspect it's a bug in Ubuntu's window manager.
Comment 4 David Ferguson 2012-02-17 11:29:34 UTC
It happens 100% of the time for me.  I'm using Virtual Box to run Ubuntu 11.10.  I believe I have Unity 2D as the window manager.
Comment 5 Jeffrey Stedfast 2012-02-17 12:04:26 UTC
I'm running Ubuntu 11.10 in VirtualBox as well.

But what version of Mono and what version of MonoDevelop?

I built and installed my own:

* Mono from trunk of the mono-2-10 git branch
* MonoDevelop from git master
* mono-addins from git master
* gtk-sharp from trunk of gtk-sharp-2-12-branch
Comment 6 David Ferguson 2012-02-17 12:15:02 UTC
I'm running the master of mono as of last week.  I typically update my MD every other day or so using the monodevelop-latest ppa found here:

Comment 7 Jeffrey Stedfast 2012-02-17 16:39:57 UTC
I still can't reproduce...
Comment 8 Jeffrey Stedfast 2012-02-17 17:04:16 UTC
I've tried using monodevelop-latest packages as well, still can't reproduce.

I've tried running monodevelop in fullscreen and non-fullscreen modes to see if that made a difference. Still can't reproduce.

I give up.
Comment 9 Jeffrey Stedfast 2012-02-21 12:38:52 UTC
This is a compiz bug.

*** This bug has been marked as a duplicate of bug 3556 ***