Bug 349 - Socket's BeginConnect never calls the callback
Summary: Socket's BeginConnect never calls the callback
Alias: None
Product: Class Libraries
Classification: Mono
Component: System ()
Version: 2.10.x
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: Untriaged
Assignee: Bugzilla
Depends on:
Reported: 2011-08-20 01:42 UTC by Ludovic
Modified: 2011-08-20 17:45 UTC (History)
2 users (show)

Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on GitHub or Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description Ludovic 2011-08-20 01:42:35 UTC
In Mono 2.10.4, connecting to a socket with the synchronous "Connect" method works fine, but doesn't work with the async "BeginConnect" method: the supplied async-callback method never gets called. Also, the async-result returned from "BeginConnect" has a wait handle that never finishes waiting either.

The end result is that any code using "BeginConnect" will freeze indefinitely.
Comment 1 Gonzalo Paniagua Javier 2011-08-20 12:03:12 UTC
Please, attach a small test case that does exactly what your program is doing. I tried a simple test of my own and it worked fine.
Comment 2 Ludovic 2011-08-20 16:28:14 UTC
Oh interesting. I was running with Mono 2.10.2 when I encountered the bug. I upgraded to 2.10.4 and *thought* the bug was still there, but my MonoDevelop was probably still running things with 2.10.2.

So yeah, it's all good, the bug seems to have been fixed in 2.10.3 or 2.10.4.

Sorry for the trouble.
Comment 3 Gonzalo Paniagua Javier 2011-08-20 17:45:33 UTC
Woohoo! Thanks for verifying that this was not a problem.