Bug 34878 - [Google Maps iOS] PanoramaView not using set heading or FOV on many iOS devices.
Summary: [Google Maps iOS] PanoramaView not using set heading or FOV on many iOS devices.
Alias: None
Product: Components
Classification: Xamarin
Component: Xamarin Components ()
Version: Production (addons.xamarin.com)
Hardware: PC Mac OS
: --- normal
Target Milestone: ---
Assignee: Israel Soto [MSFT]
Depends on:
Reported: 2015-10-14 15:51 UTC by Jon Goldberger [MSFT]
Modified: 2015-11-05 17:45 UTC (History)
2 users (show)

Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description Jon Goldberger [MSFT] 2015-10-14 15:51:22 UTC
Created attachment 13338 [details]
Test Project

## Description

On most iOS devices (not all) the heading and FOV settings are not honored and instead always use a value of heading = 0 and FOV = 1. I could not reproduce this issue on any simulator I tried. 

I ran a test in test cloud and these were the results on which devices used the set heading/FOV and which did not:


iOS 9.0.2
Ipad Air 2: bad
iPad Mini 4: bad
iPod Touch 6th gen: bad

iOS 9.0
iPad Air: bad
iPad Mini 3: bad
iPad Mini 4: bad
iPad Mini Retina: bad
iPhone 5s: bad
iPhone 6: bad
iPhone 6 Plus: bad
iPhone 6s: bad
iPhone 6s Plus: bad
iPod Touch 6th Gen: bad

iOS 9.0.2
iPad Mini: good
iPhone 5s (local test, 5s with 9.0.2 not available on test cloud): good

iOS 9.0
iPhone 4s: good
iPhone 5: good
iPhone 5c: good

It works correctly on all of the simulators I tested. 

## Steps to reproduce:

1. Open the attached test project and run to one of the bad devices. (Or run in test cloud, test project included)

Expected result: Panaorama View will have a tunnel effect due to 180 degree FOV. Also will have heading of 180. 

Actual result: Panaorama view is blurry due to 1 degree FOV. Also heading is 0.

##Screenshots from test cloud

## Environment

=== Xamarin Studio ===

Version 5.10 (build 811)
Installation UUID: 964c531b-d928-456b-a9ae-e1f82266b360
	Mono 4.2.1 (explicit/804ddbc)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 402010060

=== Xamarin.Profiler ===

Location: /Applications/Xamarin Profiler.app/Contents/MacOS/Xamarin Profiler

=== Apple Developer Tools ===

Xcode 7.0.1 (8228)
Build 7A1001

=== Xamarin.Mac ===

Version: (Business Edition)

=== Xamarin.Android ===

Version: (Business Edition)
Android SDK: /Users/apple/Library/Developer/Xamarin/android-sdk-mac_x86
	Supported Android versions:
		4.0.3 (API level 15)
		4.1   (API level 16)
		4.2   (API level 17)
		4.3   (API level 18)
		4.4   (API level 19)
		5.0   (API level 21)
		5.1   (API level 22)
		6.0   (API level 23)

SDK Tools Version: 24.3.4
SDK Platform Tools Version: 23.0.1
SDK Build Tools Version: 23

Java SDK: /usr
java version "1.7.0_79"
Java(TM) SE Runtime Environment (build 1.7.0_79-b15)
Java HotSpot(TM) 64-Bit Server VM (build 24.79-b02, mixed mode)

=== Xamarin Android Player ===

Version: 0.6.1
Location: /Applications/Xamarin Android Player.app

=== Xamarin.iOS ===

Version: (Business Edition)
Hash: b5396c2
Branch: master
Build date: 2015-09-30 15:22:15-0400

=== Build Information ===

Release ID: 510000811
Git revision: 34cd31ea72536afab530c14d9220b286075e83cd
Build date: 2015-09-30 10:40:37-04
Xamarin addins: 8e6fccfc0c19a7e0b7b11be925f09751d827eb5c
Build lane: monodevelop-lion-cycle6

=== Operating System ===

Mac OS X 10.11.0
Darwin Jons-iMac.local 15.0.0 Darwin Kernel Version 15.0.0
    Wed Aug 26 16:57:32 PDT 2015
    root:xnu-3247.1.106~1/RELEASE_X86_64 x86_64
Comment 1 Jon Goldberger [MSFT] 2015-10-14 18:07:21 UTC
I ported the test App to XCode and was not able to reproduce the issue with an Obj-C version of the app.

Link to DL the XCode project:

You need to open the .xcworkspace for the Google Maps SDK to work. 

There is an IPA in the root of the zip file as well that can be used to test on Test Cloud. 

Screenshots from Test run using the above Obj-C version (some devices did not launch, but that may be due to my not having bothered with using Calabash as all I needed was an initial screen shot)

Comment 2 Jon Goldberger [MSFT] 2015-10-14 18:46:10 UTC
Additional note: IN the XCode project, the build failed for device due to some bit code issue with the Google Maps SDK. Turning off BitCode in the Build settings allowed the build for device. Just mentioning in case it is useful info.
Comment 3 Israel Soto [MSFT] 2015-10-22 19:16:21 UTC

It seems that the issue only appears with arm64 arch. If I run the test case on iPhone 6, with iOS 9.0.2 and armv7 arch selected, everything goes ok.

I will test the case with our latest version of Google Maps (1.10.3) to see if the issue is fixed now.

The latest version of Google Maps is located in this post of X.Forums:


Israel Soto.
Comment 4 Israel Soto [MSFT] 2015-10-22 19:29:58 UTC
It seems that issue disappeared on latest version of Google.Maps (1.10.3) located at:


Here are the screenshots with the results:

iOS 9.0 devices: https://www.dropbox.com/s/793t95fuix68cp5/GoogleMapsPanorama_iOS9.0_TestResult.png?dl=0
iOS 9.0.2 devices: https://www.dropbox.com/s/7lzb343k5jz3o7u/GoogleMapsPanorama_iOS9.0.2_TestResult.png?dl=0

Israel Soto.
Comment 6 Israel Soto [MSFT] 2015-10-29 16:45:57 UTC
Hi Robert,

The latest version of G.Maps is only available through forums for now. Please, visit the following link to learn more about this, it has a link to the latest version:


Israel Soto.
Comment 7 Robert Altland 2015-11-05 17:45:23 UTC
Thank you. This appears to have solved the issue.