Bug 34801 - SSH-based build host connection, Credential problem with german characters (ä) or Space.
Summary: SSH-based build host connection, Credential problem with german characters (ä...
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: Debugger ()
Version: 4.0.0 (C6)
Hardware: PC Windows
: --- normal
Target Milestone: 4.0.0 (C6)
Assignee: vsx
Depends on:
Reported: 2015-10-13 05:38 UTC by Lars Düwel
Modified: 2016-05-10 17:02 UTC (History)
7 users (show)

Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description Lars Düwel 2015-10-13 05:38:49 UTC
I tried to authenticate with my normal iOS User "Lars Düwel" but always got the error "wrong credentials". With another account i created called "Test" it worked without problem and a connection could be established.
Comment 1 Enzo Heredia 2015-10-13 11:16:50 UTC
Hi Lars,
with "iOS User" do you mean osx user?

besides that, as far as I know you can't have a space in an account name, which is the one you use to login, you can have a space in the user name but that is not used in login process.

I tried to reproduce this issue, but when I tried to create a user with "ü", I get an error saying I can't have a especial character in user name.
Comment 2 Lars Düwel 2015-10-13 12:52:39 UTC
Hi Enzo, i will check it tomorrow when iam at work again what name i exactly had.
Comment 3 Ben Beckley 2015-10-13 15:10:39 UTC
Hello Lars, thank you for taking the time to file this. I think there may be an issue when trying to connect with an OS X account's full name if it contains characters outside of the basic Latin script. 

Each OS X account has an account name and a full name. The account name is the one that is used for the home folder and can not have "special" characters in it (as Enzo said). The full name is the one that you see on the menu bar, and can have "special" characters. During my testing, I have found that both can be used for login credentials, although the full name (user name) should not be used in the login process as Enzo said.

After some shallow connection testing, here are my findings:

Account name: "Ben"
This works

Full name: "Benjamin Beckley"
This works

Account name: "aeiou"
This works

Full name: "ÄËÏÖÜ"
This does not work due to invalid credentials

What we can take from this is pretty straightforward. Spaces in a full name can be used, and that "ÄËÏÖÜ" as a full name does not work - most likely due to the "special" characters.

Environment info:
Comment 4 Enzo Heredia 2015-10-13 15:26:56 UTC
this is Correct Ben, now Im able to reproduce.
Comment 5 Enzo Heredia 2015-10-13 15:44:02 UTC
Hi Lars,
So I made some research into this, and ssh does not allow especial characters. You can check in Sharing, when you enable the remote login, you'll see something like this:

To log in to this computer remotely, type "ssh larsduwel@".

You will notice the command does not include ü because it was replaced with u.

So now if you go to Visual Studio connection flow and type the given user name, you'll be able to login.

Please let me know if you were able to do it.

Comment 6 Lars Düwel 2015-10-14 04:01:47 UTC
Hi Enzo, Hi Ben,

thanks for the fast response, you are right. If i use the username instead of the fullname to login everything works seamlessly. I wasn't aware of the fact that the full name and username differs.

Kind Regards