Bug 34657 - Using DocuSign's signing causes a crash
Summary: Using DocuSign's signing causes a crash
Alias: None
Product: Forms
Classification: Xamarin
Component: iOS ()
Version: 1.5.0
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: ---
Assignee: Bugzilla
Depends on:
Reported: 2015-10-07 16:43 UTC by Carlos Cruz
Modified: 2017-06-17 00:56 UTC (History)
2 users (show)

Is this bug a regression?: ---
Last known good build:

Stack Trace (10.46 KB, text/plain)
2015-10-07 16:43 UTC, Carlos Cruz

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description Carlos Cruz 2015-10-07 16:43:48 UTC
Created attachment 13230 [details]
Stack Trace

Ever since I've tried updating my iPad to iOS 9, I'm running into some issues with the WebView and signing DocuSign e-documents. My app keeps crashing while the user is attempting to sign a document via DocuSign's website. I have attached the stack trace that I receive (along with a few extra lines that might be helpful).

I've also created a sample project that will help in reproducing the issue I am facing. The source can be found here: 


There is a small obstacle to overcome in order to test this. DocuSign's signing URLs are only valid once per visit. In order to test this properly, you will need a DocuSign URL. There is also something to watch out for to make testing this easier. Don't click on the 'Adopt & Sign' button that pops up. This will sign the test document and make it much more difficult to test.

I am testing using an iPad2, but I'm sure that the iOS Simulator will work just fine. You will need a signing URL which you can get using this REST request (it's the document_url): 


Once you have this, replace the existing signing URL in the TESTAPP.cs class in the TESTAPP PCL project and follow these steps:

    Click on the yellow Review Document button.
    Click on the Sign button at the bottom left of the first page.
    This should crash the app. If it doesn't, click on the red x on the top right and try again. It usually crashes on the first try, but it might take a couple attempts to get the crash to happen.


I've noticed the following things:

    The crash doesn't happen if I make a simple app with XCode with just a Web View on it that pulls up the doc.
    The crash doesn't happen if I make a simple app with Xamarin iOS (no forms) with just a UIWebView on it that pulls up the doc.
    The crash does happen if I try to make a custom PageRenderer with a UIWebView on it and try to use it in a Xamarin Forms project to pull up the doc.


I've created a thread on the forums for this bug as well: https://forums.xamarin.com/discussion/52566/webview-issue-with-docusign
Comment 1 Parmendra Kumar 2016-02-22 19:12:47 UTC
I have tried to reproduce this issue multiple times but unable to reproduce the  reported behavior given in the bug description.

It would be great if you provide Some more steps, Screencast, Ide logs, Device Logs and Environment info to reproduce the reported behavior.

You get these information from here:

Environment Info: Xamarin Studio >> About Xamarin Studio
Device Logs: Open Xcode >> Devices >> Device Logs
Ide Logs: Help >> Open Log Directory

Comment 2 David Ortinau [MSFT] 2017-06-17 00:56:24 UTC
Because we have not received a reply to our request for more information we are closing this issue. If you are still encountering this issue, please reopen the ticket with the requested information. Thanks!