Bug 34614 - Unable to connect to mac agent
Summary: Unable to connect to mac agent
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: iOS ()
Version: 4.0.0 (C6)
Hardware: Macintosh Windows
: --- normal
Target Milestone: ---
Assignee: Bugzilla
Depends on:
Reported: 2015-10-06 19:14 UTC by Josh Gretz
Modified: 2015-12-16 04:33 UTC (History)
6 users (show)

Is this bug a regression?: ---
Last known good build:

Logs for failed connection to mac from xamarin in vs (2.91 KB, application/zip)
2015-10-07 21:12 UTC, Josh Gretz

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description Josh Gretz 2015-10-06 19:14:02 UTC
I am on Yosemite. I have enabled sharing. It sees my mac, but after I enter my credentials, I am told "Couldn't connect to <name>. Please try again."

I have verified my credentials are correct. I am in the process of updating to El Capitan to see if that changes anything.
Comment 1 Josh Gretz 2015-10-06 20:58:24 UTC
I have now upgraded to El Capitan - same results.

I realized that Ieft one other major part out that i think is probably part of the cause - I am running the latest Parallels
Comment 2 Jose Gallardo 2015-10-07 08:08:54 UTC
Hi Josh,

The new Xamarin Mac Agent should work on either El Capitan or Yosemite.

It relies on standard SSH connectivity, which is enabled on the Mac by checking the Remote Login option as described in the instructions screen.

The Mac servers list show you both known servers and machines with ssh enabled in your network.

If you see your Mac in that list can be because it was already a Build Server, which can be removed by right clicking it and selecting "Forget this Mac", or because it was successfully configured for enabling ssh (which might be the case as per your comments).

Can you please attach the zipped logs after a failed connection (menu Help - Xamarin - Zip logs) so we can get more information?

If you can also confirm that you're able to connect using a Windows shh client to the Mac that would be very helpful.

Finally, are you using shared or bridged network on Parallels? Can you please try with both configurations?

Comment 3 Josh Gretz 2015-10-07 21:11:37 UTC
When I right click, Forget This Mac is greyed out and unavailable

I am able to SSH from the same windows box to my mac

I tried both shared and bridged to test it - same results. (For my situation, shared is required though)

Logs coming ...
Comment 4 Josh Gretz 2015-10-07 21:12:11 UTC
Created attachment 13235 [details]
Logs for failed connection to mac from xamarin in vs

Here are the logs as requested
Comment 5 Jose Gallardo 2015-10-13 11:52:35 UTC
Thanks Josh for the logs and my apologies for the delay.
Unfortunately there is no much info on the logs, but that helped us to realize we need better logging when the Broker cannot be started on the Mac during the connection. We've already added more log and if needed, we can hand out a build which gathers more info on that kind of failure to you.

In the meantime, we think the issue is while trying to start the Broker, which is the process running on the Mac, orchestrating most of the Xamarin Mac Agent (XMA) communication.

Can you please open a Terminal window on your Mac, and go to the following path?


Being on that path, can you please try to execute the following?

mono Broker.exe

What we see as a potential cause of the issue, is that this process cannot start on your Mac, and that call should have the same issue, and probably show the root cause of why it cannot be started as an error on the terminal window.

Can you please confirm us if that call fails, and if it does, what errors do you get?

Thank you.
Comment 8 Josh Gretz 2015-10-16 09:43:32 UTC
Sorry for the delay, I had a build to get out he past couple of days and didnt have the time until this morning to go back to the alpha channel

All that said, I switched over the alpha channel this morning can stay here for a week or so.

Interestingly enough, when I switched back over today, Visual Studio was able to connect to my Mac. Unfortunately, I am now running into a different issue - I am unable to complete a build of my project (which builds on the Beta branch). The following is my observation: the build seems to spin off and try to build all four of my projects in parallel, and the build then fights over one of my nuget package dlls (automapper is the one its choking on, but i think thats due to it being alphabetically first). I did manually clean out the obj and bin directories, and tried to rebuild - but ran into the same issues.

Let me know what else I can give you
Comment 9 Jose Gallardo 2015-10-16 16:38:22 UTC
Can you please set the Build output verbosity level to Diagnostic (Tools - Options - Projects & Solutions - Build & Run)
"MSBuild project build output verbosity” and “MsBuild project build log file verbosity"

And send us the output there?

Also, updated logs would be great.

Comment 10 Josh Gretz 2015-10-19 08:25:22 UTC
So I didnt change anything between Friday and today (except a couple of reboots and the output setting requested above) but now it builds without issue.

I guess you can close this bug until / unless it re-occurs. 

thanks for your help along the way
Comment 11 PJ 2015-12-02 21:03:11 UTC
Thanks for following up, Josh. Sorry you hit the issue in the first place. Since we were unable to reproduce but there's not any more action on this bug, marking as RESOLVED NOT_REPRODUCIBLE. Please let us know if you hit the issue again.