Bug 34523 - Locals don't refresh after await call
Summary: Locals don't refresh after await call
Status: RESOLVED NORESPONSE
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Debugger ()
Version: 5.9
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: master
Assignee: David Karlaš
URL:
Depends on:
Blocks:
 
Reported: 2015-10-02 10:45 UTC by aaronbratcher1
Modified: 2017-05-15 21:39 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED NORESPONSE

Description aaronbratcher1 2015-10-02 10:45:23 UTC
It seems that after an await call, when a break point is hit the locals window doesn't refresh the reality of the local variables shown when hovering over them. See attached screenshot.


Xamarin details:

Xamarin Studio
Version 5.9.7 (build 9)
Installation UUID: b3bd43ab-8f5a-414b-9685-aa50e7661a15
Runtime:
	Mono 4.0.4 ((detached/d481017)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 400040004

Xamarin.Android
Version: 5.1.6.7 (Enterprise Edition)
Android SDK: /Users/aaronbratcher/Library/Developer/Xamarin/android-sdk-macosx
	Supported Android versions:
		4.0.3 (API level 15)
		4.4   (API level 19)
		5.0   (API level 21)
Java SDK: /usr
java version "1.7.0_71"
Java(TM) SE Runtime Environment (build 1.7.0_71-b14)
Java HotSpot(TM) 64-Bit Server VM (build 24.71-b01, mixed mode)

Xamarin Android Player
Not Installed

Apple Developer Tools
Xcode 7.0.1 (8228)
Build 7A1001

Xamarin.iOS
Version: 9.0.1.20 (Enterprise Edition)
Hash: d8e9592
Branch: master
Build date: 2015-09-18 23:22:05-0400

Xamarin.Mac
Version: 2.0.2.111 (Starter Edition)

Build Information
Release ID: 509070009
Git revision: 31fa64709030b3edb971237780a452a4c69943c4
Build date: 2015-09-17 11:44:37-04
Xamarin addins: b105d33d8cd72911ff2cf3ee0b7715d37e5f19a6

Operating System
Mac OS X 10.11.0
Darwin Aarons-MBP 15.0.0 Darwin Kernel Version 15.0.0
    Wed Aug 26 16:57:32 PDT 2015
    root:xnu-3247.1.106~1/RELEASE_X86_64 x86_64
Comment 1 David Karlaš 2015-10-04 05:30:07 UTC
Missing attachment. Can you give more details on how to reproduce?
Comment 2 Kirill Osenkov 2017-05-15 21:39:54 UTC
We're resolving this for now, but please feel free to reactivate or open a new bug if you have more information for us. Thanks!