Bug 34505 - ClassNotFoundException: NetworkChangeReceiver Xamarin Insights at startup in Release mode
Summary: ClassNotFoundException: NetworkChangeReceiver Xamarin Insights at startup in ...
Alias: None
Product: Android
Classification: Xamarin
Component: Mono runtime / AOT Compiler ()
Version: unspecified
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: ---
Assignee: Jonathan Pryor
Depends on:
Reported: 2015-10-01 17:03 UTC by David
Modified: 2017-06-28 11:38 UTC (History)
6 users (show)

Tags: BZCU
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description David 2015-10-01 17:03:48 UTC
I have this snippet in my splash screen activity:

Insights.HasPendingCrashReport += (sender, isStartupCrash) =>
				if (isStartupCrash) {

When I run my application in Debug mode everything works fine. Once I use the Release mode I get this exception:

java.lang.ClassNotFoundException: md55caa6fe88082d2d5789caeda3e8fc56c.NetworkChangeReceiver
[MonoDroid] 	at dalvik.system.BaseDexClassLoader.findClass(BaseDexClassLoader.java:61)
[MonoDroid] 	at java.lang.ClassLoader.loadClass(ClassLoader.java:501)
[MonoDroid] 	at java.lang.ClassLoader.loadClass(ClassLoader.java:461)
[MonoDroid] 	at md589553ae39897acf0d48e8e2e4217ef52.SplashScreenActivity.n_onCreate(Native Method)
[MonoDroid] 	at md589553ae39897acf0d48e8e2e4217ef52.SplashScreenActivity.onCreate(SplashScreenActivity.java:28)
[MonoDroid] 	at android.app.Activity.performCreate(Activity.java:5010)
[MonoDroid] 	at android.app.Instrumentation.callActivityOnCreate(Instrumentation.java:10

This worked perfectly until a recent update of Xamarin or probably Insights.
Comment 1 Ashley Gazich [MSFT] 2015-10-07 15:59:38 UTC
Hi David, thanks for submitting your report. 

When you have a chance, will you please add your version information and a sample project demonstrating the issue?

Visual Studio: Help > About Microsoft Visual Studio > Copy Info [button]
Xamarin Studio > About Xamarin Studio > Show Details > Copy Information [button]

Comment 2 Ali 2016-06-13 09:02:13 UTC
I get this error as well, not only in release but also in debug. (not in android >=5 though)
Comment 3 Jonathan Pryor 2016-06-15 02:20:54 UTC
Please provide a repro.
Comment 4 Adam Hartley [MSFT] 2017-06-28 11:38:59 UTC
Because we have not received a reply to our request for more information we are closing this issue. If you are still encountering this issue, please reopen the ticket with the requested information. Thanks!