Bug 34233 - Constraint from CenterY of a button misrenders
Summary: Constraint from CenterY of a button misrenders
Status: VERIFIED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: iOS Designer ()
Version: unspecified
Hardware: PC Mac OS
: --- normal
Target Milestone: master
Assignee: Jose Medrano
URL:
Depends on:
Blocks:
 
Reported: 2015-09-24 07:21 UTC by Jose Medrano
Modified: 2016-09-19 14:51 UTC (History)
5 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description Jose Medrano 2015-09-24 07:21:08 UTC
Steps to reproduce:

1) Create a ViewController
2) Drop a Button
3) Create a constraint from center to horizontal line

Result: draw a vertical constraint line with wrong position 
Expected : draw a horizontal constraint line

Screencast: http://quick.as/nd08fvow7
Comment 1 xamarin-release-manager 2015-10-01 07:42:41 UTC
Fixed in version 5.11.0.232 (master)

Author: Jose?? Medrano
Commit: 02f6c13d64633c401c4865d67c154bab47d6117f (xamarin/md-addins)
Included in Commit: 53db663b42cd37eaf0cfcdb4d558edb083fa4cd9 (mono/monodevelop)
Comment 2 narayanp 2016-09-19 14:51:33 UTC
I have checked this issue with latest master XamarinStudio 6.2.0.530 build and observed that now the issue is working fine.

Please refer to the screencast.

Screencast: http://www.screencast.com/t/pmuxoK9H2UKK

Environment Info:
gist: https://gist.github.com/lal360/9070f991f5433e51bab81c64bf45fa3f