Bug 34153 - Upload to device fails with 'invalid resource specification rule(s)'
Summary: Upload to device fails with 'invalid resource specification rule(s)'
Status: RESOLVED DUPLICATE of bug 31424
Alias: None
Product: iOS
Classification: Xamarin
Component: Xamarin.iOS.dll ()
Version: XI 9.0 (iOS9)
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: Untriaged
Assignee: Bugzilla
Depends on:
Reported: 2015-09-22 05:48 UTC by Kai Hartmann
Modified: 2015-09-24 06:10 UTC (History)
3 users (show)

Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description Kai Hartmann 2015-09-22 05:48:40 UTC
We got an error when trying to deploy our iOS application to a device, but executing the application via Simulator works.

We updated the OS X (10.10.5), Xamarin (5.9.7 (build 9)), and XCode () beforehand. Before the update everything worked fine.

The complete error message we got is:

Signing application
codesign -v --force --sign "301F3E40BED0D52CAC9A7541C6EB7BEE35829F43" --entitlements "/Users/develop/Projects/cubeeMobile/cubeeMultiView/bin/iPhone/Debug/cubeeMobile.xcent" "/Users/develop/Projects/cubeeMobile/cubeeMultiView/bin/iPhone/Debug/cubeeMobile.app"
/Users/develop/Projects/cubeeMobile/cubeeMultiView/bin/iPhone/Debug/cubeeMobile.app: invalid resource specification rule(s)
codesign exited with code 1
Comment 1 Sebastien Pouliot 2015-09-22 08:16:57 UTC

*** This bug has been marked as a duplicate of bug 31424 ***
Comment 2 Kai Hartmann 2015-09-22 08:21:06 UTC
Any information about 31424? I do not have access...
Comment 3 Sebastien Pouliot 2015-09-22 08:59:27 UTC
@Kai it is a Xamarin Studio (iOS addin) issue that affects Classic (not unified) projects. It's fixed but I do not know when it will be released (you can contact support).

Also the XS 5.10.x builds (from the alpha channel) works correctly - at least the version I'm using.
Comment 4 Kai Hartmann 2015-09-22 10:51:49 UTC
Thx for the information. It does not work for me though, saying something about assembly 'System' and 'mscorlib' already existing with the same identity... I guess I wait for the stable release then.
Comment 6 Brendan Zagaeski (Xamarin Team, assistant) 2015-09-22 16:44:28 UTC
I have added Bug 31424 to the corresponding forum release announcement for
Xamarin.iOS 9.0 to track its progress publicly:


One possible workaround is mentioned there: switch the project to use the
MSBuild build engine.

If you run into trouble with the workaround, the fix for Bug 31424 is due to be released in the upcoming service release for Xamarin.iOS 9.0, tentatively scheduled for Beta within approximately one week.
Comment 7 Kai Hartmann 2015-09-23 02:13:58 UTC
Thank you for the information. Switching to MSBuild unfortunately gives me the same errors as when using the alpha. I'll see how the Beta works.
Comment 8 Brendan Zagaeski (Xamarin Team, assistant) 2015-09-23 12:00:09 UTC
Note that you will need to clean the `bin` and `obj` folders after switching to MSBuild, on the small chance that might be helpful to know.
Comment 9 Kai Hartmann 2015-09-24 06:10:07 UTC
I still get the errors even after deleting the contents of 'bin' and 'obj'. But thank you for the hint.