Bug 34054 - During debugging, window asks "Where is iOS Simulator?"
Summary: During debugging, window asks "Where is iOS Simulator?"
Status: VERIFIED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Debugger ()
Version: 5.9
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: master
Assignee: David Karlaš
URL:
Depends on:
Blocks:
 
Reported: 2015-09-18 06:56 UTC by MPH
Modified: 2015-10-15 14:26 UTC (History)
7 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Screenshot (some folder names omitted) (279.94 KB, image/png)
2015-09-18 06:56 UTC, MPH
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description MPH 2015-09-18 06:56:11 UTC
When debugging, after resuming from a watchpoint, a dialog box will popup asking "Where is iOS Simulator?"  However, after cancelling it, you can resume debugging.  Resuming after any further watchpoints will cause the dialog to appear again.

This is using Xamarin on a fresh install of El Capitan with XCode 7 GM.
Comment 1 MPH 2015-09-18 06:56:34 UTC
Created attachment 12941 [details]
Screenshot (some folder names omitted)
Comment 2 David Karlaš 2015-09-18 08:36:06 UTC
Can you explain in more detail what you mean by "resuming from a watchpoint" you mean after breakpoint is hit and you press Run->Continue Debugging(in top menu)?
Comment 3 Matt Ward 2015-09-18 12:54:31 UTC
I can repro this on Yosemite with Xcode7 and Xamarin Studio 5.9.7.

My repro steps are:

1) Create a new iOS Single view app. 
2) Put a breakpoint on the Xamarin.Calabash.Start line in the AppDelegate.
3) Run - Start Debugging.
4) When breakpoint is hit then select Run - Continue Debugging.
Then the Where is iOS Simulator window appears.


Most of the Xamarin software is from the stable channel apart from Xamarin.Mac 2.3 and Mono 4.2.

Xamarin Studio
Version 5.9.7 (build 9)
Installation UUID: 2e3bd8f5-b157-4b31-aa56-d9c12536e261
Runtime:
	Mono 4.2.0 (explicit/1d2c582)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 402000185

Apple Developer Tools
Xcode 7.0 (8227)
Build 7A220

Xamarin.iOS
Version: 9.0.1.18 (Business Edition)
Hash: d230615
Branch: master
Build date: 2015-09-16 17:04:13-0400

Xamarin.Android
Version: 5.1.6.7 (Business Edition)
Android SDK: /Library/Developer/Xamarin/android-sdk-macosx
	Supported Android versions:
		2.3   (API level 10)
		4.0.3 (API level 15)
		4.4   (API level 19)
		5.0   (API level 21)
		5.1   (API level 22)
Java SDK: /usr
java version "1.7.0_71"
Java(TM) SE Runtime Environment (build 1.7.0_71-b14)
Java HotSpot(TM) 64-Bit Server VM (build 24.71-b01, mixed mode)

Xamarin Android Player
Version: Unknown version
Location: /Applications/Xamarin Android Player.app

Xamarin.Mac
Version: 2.3.0.135 (Business Edition)

Build Information
Release ID: 509070009
Git revision: 31fa64709030b3edb971237780a452a4c69943c4
Build date: 2015-09-17 11:44:37-04
Xamarin addins: b105d33d8cd72911ff2cf3ee0b7715d37e5f19a6

Operating System
Mac OS X 10.10.5
Darwin l 14.5.0 Darwin Kernel Version 14.5.0
    Wed Jul 29 02:26:53 PDT 2015
    root:xnu-2782.40.9~1/RELEASE_X86_64 x86_64
Comment 4 xamarin-release-manager 2015-09-22 04:59:38 UTC
Fixed in version 5.11.0.159 (master)

Author: David Karlas??
Commit: c82b44d90b42e91783f9693ffacdea62598a6aee (xamarin/md-addins)
Included in Commit: 6b6c4950fe1a03f6bd6e25567ed826cf40df1c2f (mono/monodevelop)
Comment 5 Shruti 2015-09-23 06:18:40 UTC
@Matt, I have tried to reproduce this issue by following steps mentioned in comment(3) using same builds but not able to reproduce this issue. Every time selected simulator is launching successfully. I tried to reproduce it on 2 different systems with following environments

Environment Info(1) : https://gist.github.com/Shruti360/99cf5d1b7115e9b68c1d
Environment Info(2) : https://gist.github.com/anonymous/9ff85468646daa137d85

Please let me know Do I need to follow any other step to reproduce this issue?
Comment 6 Matt Ward 2015-09-23 06:21:20 UTC
@Shruti - The steps are those in comment #3 there are no other steps that I know of to reproduce it.
Comment 7 David Karlaš 2015-09-23 06:26:31 UTC
@Shruti, once application is running press pause button(or place breakpoint) and then resume again with play button.
Comment 8 Shruti 2015-09-23 06:40:48 UTC
I have tried it with both ways : 
1. Place breakpoint before running application
2. Place breakpoint while running application.

In both cases, not able to reproduce it. 
Screencast for same: http://www.screencast.com/t/0UHRAUXc
Comment 9 David Karlaš 2015-09-23 06:59:25 UTC
Ok, looks like that showing that popup depends from system to system...

@Shruti... for you this bug appears as iOS Simulator not showing up after resuming program.

So if you try on XCode 6 computer, after pressing Resume iOS Simulator will come into focus... But with XCode 7 it won't come in front of XS...

After this fix it will come in front of XS again.
Comment 10 Tim Brand 2015-09-23 07:33:24 UTC
Any idea when this fix will be available? As the beta channel is on 5.9 and the alpha on 5.10.
The popup is getting very annoyed now as i'm doing a lot of debugging now.
thanks!
Comment 11 Randy 2015-09-23 13:26:17 UTC
I just started getting this popup today too. The dialog would appear after resuming from each breakpoint.

As a guess, I tried selecting 'XCode' from the dialog and now the problem is gone.
Comment 12 Shruti 2015-09-24 07:40:29 UTC
Thanks David for giving more clarification of this issue in comment(9). I have checked this issue with XS Version 5.11 (build 175) and observed that now iOS Simulator is showing up after resuming the program. 

Screencast: http://www.screencast.com/t/ei0TRpSh

So I am verifying this issue with master XS Version 5.11 (build 175) .

Environment Info:
=== Xamarin Studio ===

Version 5.11 (build 175)
Installation UUID: 67eaf3b4-f8a7-4ab4-a9df-3197350ca5dc
Runtime:
	Mono 4.0.4 ((detached/cb6d6b2)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 400040002

=== Xamarin.Profiler ===

Version: 0.15.132.0
Location: /Applications/Xamarin Profiler.app/Contents/MacOS/Xamarin Profiler

=== Apple Developer Tools ===

Xcode 7.0 (8227)
Build 7A220

=== Xamarin.Mac ===

Version: 2.0.2.111 (Business Edition)

=== Xamarin.iOS ===

Version: 9.0.1.20 (Business Edition)
Hash: d8e9592
Branch: master
Build date: 2015-09-18 23:22:05-0400

=== Xamarin.Android ===

Version: 6.0.0.0 (Enterprise Edition)
Android SDK: Not found

=== Xamarin Android Player ===

Version: 0.4.4
Location: /Applications/Xamarin Android Player.app

=== Build Information ===

Release ID: 511000175
Git revision: 0010a9b2788d1b0e66327f8d41fd8734108ff1b8
Build date: 2015-09-24 07:17:58-04
Xamarin addins: e4b95fae0042bff41409c1add8fb0bb98d38bc98
Build lane: monodevelop-lion-master

=== Operating System ===

Mac OS X 10.10.4
Darwin XamnewiMac.local 14.4.0 Darwin Kernel Version 14.4.0
    Thu May 28 11:35:04 PDT 2015
    root:xnu-2782.30.5~1/RELEASE_X86_64 x86_64

=== Enabled user installed addins ===

Test Template Parameters 0.2
Comment 15 xamarin-release-manager 2015-09-28 12:38:22 UTC
Fixed in version 5.10.0.804 (cycle6)

Author: David Karla??
Commit: 9132fa9cdfabb16db8291aebff99e2ba4736449a (xamarin/md-addins)
Included in Commit: 5279c3ca6e01c79ce4d8e9918853245efe632140 (mono/monodevelop)
Comment 16 Shruti 2015-09-29 03:49:46 UTC
I have checked this issue with iOS9 builds+Xcode7 as well, now iOS Simulator is showing up after resuming the program. 
 Screencast: http://www.screencast.com/t/lpWNUgvVYgFG

Environment Info: https://gist.github.com/Shruti360/92bc603577d3d63e5ff5
Comment 17 xamarin-release-manager 2015-09-30 12:15:55 UTC
Fixed in version 5.9.7.22 (monodevelop-5.9-branch-android-m-preview)

Author: David Karla??
Commit: 9f0bdbe17ab740ee9f825a6fbbdcac498536a18c (xamarin/md-addins)
Included in Commit: 6bd1f169df44ca96addf8a035316c535a4fa46fa (mono/monodevelop)
Comment 18 Shruti 2015-10-08 03:23:24 UTC
Working fine with  C6 XS 5.10.0.813_388e41428fb8f2910833c87fec0e7edaccd4f436. 
Screencast: http://www.screencast.com/t/j1H2BS7A7X

Environment Info: https://gist.github.com/Shruti360/e6a03cb96a00d4ea7eff
Comment 19 xamarin-release-manager 2015-10-15 14:26:41 UTC
Fixed in version 5.9.6.23 (monodevelop-5.9-branch)

Author: David Karla??
Commit: 9f0bdbe17ab740ee9f825a6fbbdcac498536a18c (xamarin/md-addins)
Included in Commit: cc4cd949960c4fc9864b0d36bd3bc1b9fcf14834 (mono/monodevelop)