Bug 33931 - User is not able to migrate from X.Mac classic API to X.Mac Unified API.
Summary: User is not able to migrate from X.Mac classic API to X.Mac Unified API.
Status: RESOLVED UPSTREAM
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Mac Add-in ()
Version: 5.10 (C6SR3)
Hardware: PC Mac OS
: High major
Target Milestone: master
Assignee: Chris Hamons
URL:
Depends on:
Blocks:
 
Reported: 2015-09-14 09:19 UTC by Rajneesh Kumar
Modified: 2017-05-30 21:45 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED UPSTREAM

Comment 1 Chris Hamons 2015-09-14 17:34:28 UTC
If you do the migration w/ only one project in the solution does it work? Could you attach the project as well?
Comment 5 Vincent Dondain [MSFT] 2017-05-30 21:45:07 UTC
Seems to be working fine now (:

I tried your samples from comment 2 with the following environment: https://gist.github.com/VincentDondain/2fd61871afd370f7ffb36e8c4b7cda54

Tried the migration to Modern && Full, both worked.

I consider this resolved upstream.