Bug 33930 - Sync between xcode and designer broken
Summary: Sync between xcode and designer broken
Status: RESOLVED NORESPONSE
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: iOS Designer ()
Version: 5.10 (C6SR3)
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: master
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2015-09-14 08:58 UTC by Paul Johnson
Modified: 2015-10-26 21:57 UTC (History)
4 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED NORESPONSE

Description Paul Johnson 2015-09-14 08:58:46 UTC
Due to a couple of limitations in the designer (such as not being able to copy and paste from an existing xib into a VC on the designer), I have to edit my storyboard in xcode.

When I do this, XS throws up an error that it can't sync and an exception has been raised. The altered storyboards have saved fine (reload into xcode and the changes show), but the designer shows the last design it had for that VC

Using XS 5.10 (build 704)
Xam.iOS 8.10.5.26 (business)
OS X 10.10
Xcode 6.4 (6E35b)
Comment 1 Alan McGovern 2015-09-15 04:16:56 UTC
Can you screencast the problem and also attach the log files? This sounds like an Xcode integration issue, not an iOS designer issue.
Comment 2 Paul Johnson 2015-09-15 04:20:35 UTC
Yep though it may not be until tomorrow when I'm back home (work is touchy on installing video cap software - even the likes of jing)
Comment 3 Alan McGovern 2015-09-15 04:23:11 UTC
No problem. Without the error messages or a way to reproduce the problem it's hard to figure out what's going wrong. Including the log files from the XS Log Directory would probably help too. They should have the details of exactly what went wrong and why.
Comment 4 Alan McGovern 2015-09-30 06:32:03 UTC
Any update on this? Without further information we won't be able to figure out the issue.
Comment 5 Alan McGovern 2015-10-26 21:57:02 UTC
Without further information it's not possible for us to tell what is going on. I'll closing this until we get more info on the problem.