Bug 33860 - Error XA5101 - Platform Library Directory API Level 23 Not Found
Summary: Error XA5101 - Platform Library Directory API Level 23 Not Found
Status: RESOLVED DUPLICATE of bug 32770
Alias: None
Product: Android
Classification: Xamarin
Component: General ()
Version: 5.1
Hardware: All All
: --- normal
Target Milestone: ---
Assignee: Jonathan Pryor
Depends on:
Reported: 2015-09-10 16:32 UTC by Hines Vaughan III
Modified: 2015-09-17 17:11 UTC (History)
2 users (show)

Tags: android api 23 XA5101 archive for publishing
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description Hines Vaughan III 2015-09-10 16:32:53 UTC
Using the latest version of Xamarin Studio and the latest version of everything within the Android SDK Manager, I am able to build and run the Xamarin Forms project on Android without any issues, but when I try to 'Archive for Publishing' I receive the following error message:
Error XA3001: Xamarin.Android.XamarinAndroidException: error XA5101: Platform library directory for target Arm and API Level 23 was not found. Expected path is "/Users/[user account]/Library/Developer/Xamarin/android-ndk/android-ndk-r10d/platforms/android-23/arch-arm/usr/lib"
  at Xamarin.Android.Diagnostic.Error (Int32 code, System.String message, System.Object[] args) [0x00000] in <filename unknown>:0 
  at Xamarin.Android.Tasks.NdkUtil.GetNdkPlatformLibPath (System.String androidNdkPath, AndroidTargetArch arch, Int32 level) [0x00000] in <filename unknown>:0 
  at Xamarin.Android.Tasks.Aot.DoExecute () [0x00000] in <filename unknown>:0 
  at Xamarin.Android.Tasks.Aot.Execute () [0x00000] in <filename unknown>:0  (XA3001) (APA.MAP.Droid)

We have been able to successfully archive this solution before and were able to successfully push out to the Google Play store successfully and I am not sure when this broke.

I checked in the /platforms/ directory and I indeed do not have an /android-23/ directory listed, I only have up to /android-21/. I also tried manually downloading and extracting the latest NDK package from Google and it also did not have the /android-23/ directory listed in there.

There is currently a thread in the forums with other users have the same issue:

Thanks for the help.
Comment 1 Hines Vaughan III 2015-09-10 16:42:11 UTC
Just realized that turning off the LLVM compiler allows the project to be archived successfully without the XA5101.

Also just saw that I accidentally wrote 'XA3001' in the description above. I meant to put write 'XA5101'. Thanks.
Comment 2 Jon Goldberger [MSFT] 2015-09-14 21:44:24 UTC
I was able to reproduce this issue with a template Android project on the Stable versions of Xamarin for Visual Studio and Xamarin.Android on the Mac. (Got different errors with the Alpha/Beta versions)

However this bug seems to be partially resolved with the Preview version of Xamarin Android for Android M. It resolved the issue when using in Xamarin Studio on the Mac. I did however still get the issue on Xamarin Studio on Windows/Visual Studio.

This preview version is not available in either the Stable, Beta, or Alpha channels at this time. See these release posts for info on how to install this preview:

Comment 3 Jonathan Pryor 2015-09-17 17:11:18 UTC
This looks like a DUPE of Bug #32770.

*** This bug has been marked as a duplicate of bug 32770 ***