Bug 33792 - Cannot build or Execute Hello.OS suite
Summary: Cannot build or Execute Hello.OS suite
Status: RESOLVED NORESPONSE
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: General ()
Version: unspecified
Hardware: PC Mac OS
: --- normal
Target Milestone: master
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2015-09-08 13:14 UTC by Douglas Jones
Modified: 2017-05-15 21:32 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED NORESPONSE

Description Douglas Jones 2015-09-08 13:14:03 UTC
Description of Problem:
Unable to successfully compile demo programs

Steps to reproduce the problem:
1. Download and load Hello.OS Demo apps
2. With Xamarin loaded select Build-All from main menu


Actual Results:
Resultant message - "Build: 1 Error 1 Warning, /Library/Frameworks/Mono.framework/Versions/4.0.3/lib/mono/4.5/Microsoft.CSharp.targets: Error: Compiler crashed with code: 127. (Phoneword_iOS)


Expected Results:
Successful build

How often does this happen? Every


Additional Information:
Comment 1 Matt Ward 2015-09-17 04:41:46 UTC
I assume you mean you downloaded the .zip from:

https://developer.xamarin.com/samples/monotouch/Hello_iOS/

Then tried to compile the Hello.iOS.sln.

I am unable to reproduce this. The sample compiles OK for me.

1) Can you attach the full text from Xamarin Studio - About - Show Details?

2) Can you turn go into Xamarin Studio - Preferences - Projects - Build and set Log verbosity to Diagnostic. Then build the solution again. Then copy the build output from Errors window and attach it to this bug report?
Comment 2 Kirill Osenkov 2017-05-15 21:32:41 UTC
We're closing this because we can't reproduce and the issue is now pretty stale.

Please do feel free to file a new bug if you're still seeing problems and we can then investigate with hopefully newer information. Thanks.