Bug 33737 - Monodevelop Windows Forms always transparent
Summary: Monodevelop Windows Forms always transparent
Status: NEW
Alias: None
Product: Class Libraries
Classification: Mono
Component: Windows.Forms ()
Version: unspecified
Hardware: PC Linux
: --- normal
Target Milestone: Community
Assignee: Bugzilla
Depends on:
Reported: 2015-09-07 08:23 UTC by AlphaD
Modified: 2017-09-01 11:55 UTC (History)
2 users (show)

Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report for Bug 33737 on GitHub or Developer Community if you have new information to add and do not yet see a matching new report.

If the latest results still closely match this report, you can use the original description:

  • Export the original title and description: GitHub Markdown or Developer Community HTML
  • Copy the title and description into the new report. Adjust them to be up-to-date if needed.
  • Add your new information.

In special cases on GitHub you might also want the comments: GitHub Markdown with public comments

Related Links:

Description AlphaD 2015-09-07 08:23:12 UTC
I created a simple windows form, containing only a TextBox.

When the form show up, all of his inner part (where controls lies, not counting border of the form) is completely transparent.

I tried forcing these proprierties:


but, it always show up transparent.

This problem work only with the windows forms crated by monodevelop, not with the ones created with Visual Studio.

Current Mono version: 5.9.5

SO: Linux Mint 17.2 mate x64 with codecs, all fully updated.

I tried to search for the bug and cocumentation, but I wasn't able to fnd anything, saddly.

I would be happy to help as much as I can, just asks for more details and I'll do my best to help!
Comment 1 Rodrigo Kumpera 2015-09-08 11:41:37 UTC
Looks like a XS problem
Comment 3 Lluis Sanchez 2015-09-09 08:07:42 UTC
I don't see how this can be an XS problem. We don't have any Windows Forms specific support.
Comment 4 AlphaD 2015-09-16 08:06:35 UTC
I recently discovered, that, the form don't show up without setting:


I still tring to find out more informations.