Bug 33667 - System.IO.FileNotFoundException: Could not load assembly...Perhaps it doesn't exist in the Mono for Android profile?
Summary: System.IO.FileNotFoundException: Could not load assembly...Perhaps it doesn't...
Alias: None
Product: Forms
Classification: Xamarin
Component: Forms ()
Version: 1.4.4
Hardware: PC Windows
: Normal normal
Target Milestone: ---
Assignee: Bugzilla
Depends on:
Reported: 2015-09-04 12:42 UTC by dbarbin
Modified: 2015-09-14 16:06 UTC (History)
4 users (show)

Is this bug a regression?: ---
Last known good build:

IDE Logs (1.18 MB, application/x-zip-compressed)
2015-09-10 12:00 UTC, dbarbin
Sample project (1.63 MB, application/x-zip-compressed)
2015-09-10 12:03 UTC, dbarbin

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description dbarbin 2015-09-04 12:42:18 UTC
I am receiving this exception when opening a solution containing a Xamarin.Forms PCL project and its respective Android/iOS/Windows Phone projects.  The assembly it cannot load and it is referencing is the PCL project itself.  In addition, it shows "Version=, Culture=neutral, PublicKeyToken=" after the assembly name in the exception message.  Furthermore, I get lots of errors along the lines of "InitializeComponent doesn't exist in the current context", "The type or namespace name 'App' does not exist in the namespace..."  

Cleaning the solution and restarting Visual Studio does not help.  All of this was working fine yesterday until I updated to the latest "stable" version of Xamarin.Forms.
Comment 1 Ram Chandra 2015-09-04 13:20:51 UTC
I have checked this issue but I am not able to reproduce this issue.

Could you please provide sample project and build version? So that we can reproduce this issue at our end.

You can get build info from here:
Visual Studio => About Microsoft Visual Studio => Copy Info

Environment Info:

Xamarin.Forms :
Windows: 8.1
XVS: 3.11.837
Comment 2 dbarbin 2015-09-04 13:59:17 UTC
Microsoft Visual Studio Professional 2015
Version 14.0.23107.0 D14REL
Microsoft .NET Framework
Version 4.6.00081

Installed Version: Professional

Visual Basic 2015   00322-40000-00000-AA660
Microsoft Visual Basic 2015

Visual C# 2015   00322-40000-00000-AA660
Microsoft Visual C# 2015

Visual C++ 2015   00322-40000-00000-AA660
Microsoft Visual C++ 2015

Visual F# 2015 RC   00322-40000-00000-AA660
Microsoft Visual F# 2015 RC

Windows Phone SDK 8.0 - ENU   00322-40000-00000-AA660
Windows Phone SDK 8.0 - ENU

Application Insights Tools for Visual Studio Package   1.0
Application Insights Tools for Visual Studio

ASP.NET and Web Tools   14.0.20626.0
ASP.NET and Web Tools

ASP.NET Web Frameworks and Tools 2013   5.2.30624.0
For additional information, visit http://www.asp.net/

Common Azure Tools   1.5
Provides common services for use by Azure Mobile Services and Microsoft Azure Tools.

GenerateUnitTest   1.0
Generates unit test code for methods in classes under test.

GitHub.VisualStudio   1.0
A Visual Studio Extension that brings the GitHub Flow into Visual Studio.

JetBrains ReSharper Ultimate 2015.2   Build 103.0.20150818.200216
JetBrains ReSharper Ultimate package for Microsoft Visual Studio. For more information about ReSharper Ultimate, visit http://www.jetbrains.com/resharper. Copyright © 2015 JetBrains, Inc.

Microsoft Azure Mobile Services Tools   1.4
Microsoft Azure Mobile Services Tools

Microsoft MI-Based Debugger   1.0
Provides support for connecting Visual Studio to MI compatible debuggers

NuGet Package Manager   3.0.0
NuGet Package Manager in Visual Studio. For more information about NuGet, visit http://docs.nuget.org/.

Office Developer Tools for Visual Studio 2015 ENU   14.0.23025
Microsoft Office Developer Tools for Visual Studio 2015 ENU

PreEmptive Analytics Visualizer   1.2
Microsoft Visual Studio extension to visualize aggregated summaries from the PreEmptive Analytics product.

Python Tools for Visual Studio   2.2.30718.00
Python Tools for Visual Studio provides IntelliSense, projects, templates, Interactive windows, and other support for Python developers.

Python Tools for Visual Studio - Django Integration   2.2.30718.00
Provides templates and integration for the Django web framework.

Python Tools for Visual Studio - Profiling Support   2.2.30718.00
Profiling support for Python projects.

SQL Server Data Tools   14.0.50717.0
Microsoft SQL Server Data Tools

Visual C++ for Cross Platform Mobile Development   1.0
Visual C++ for Cross Platform Mobile Development

Visual C++ for Cross Platform Mobile Development   1.0
Visual C++ for Cross Platform Mobile Development

Workflow Manager Tools 1.0   1.0
This package contains the necessary Visual Studio integration components for Workflow Manager.

Xamarin   3.11.837.0 (f10676f)
Visual Studio extension to enable development for Xamarin.iOS and Xamarin.Android.

Xamarin.Android (f98871a95a479f6d71b3067b7e5834d41fcb2118)
Visual Studio plugin to enable development for Xamarin.Android.

Xamarin.iOS (6db87c53c073f4af2f5247fb738a27ea08c094fd)
Visual Studio extension to enable development for Xamarin.iOS.

Xamarin.iOS Unified Migration   1.0
Automated migration for Xamarin iOS Classic projects to Unified

Xamarin.TestCloud.Integration   1.0
Early preview of Xamarin Test Cloud integration
Comment 3 dbarbin 2015-09-04 15:50:12 UTC
I get the same behavior in Visual Studio 2015 as well.
Comment 4 dbarbin 2015-09-04 15:50:32 UTC
Visual Studio 2013 as well.
Comment 5 dbarbin 2015-09-08 10:24:38 UTC
Do you need any additional info from me?  My Xamarin installation is completely broken.  I get these errors with any new project I start.  Reinstalling Xamarin did not help.
Comment 6 dbarbin 2015-09-09 14:44:50 UTC
Can I get a response?  I am losing days of productivity here because I chose to go with the Xamarin platform.  Right now, I am a very unsatisfied customer.
Comment 7 dbarbin 2015-09-09 14:45:03 UTC
Comment 8 Ram Chandra 2015-09-10 04:40:45 UTC
Please excuse our tardy reply. I tried to reproduce this issue and I am still not able to reproduce this issue. If you have a chance, it might also be helpful to attach "sample application" and "IDE logs". So that we can reproduce this issue at our end.

You can get IDE logs from here:
Visual studio => HELP => Xamarin => Zip Xamarin Logs (please attach zipped log with this issue).
Comment 9 dbarbin 2015-09-10 12:00:41 UTC
Created attachment 12857 [details]
IDE Logs
Comment 10 dbarbin 2015-09-10 12:03:21 UTC
Created attachment 12858 [details]
Sample project
Comment 11 dbarbin 2015-09-10 12:04:00 UTC
IDE logs and sample project are attached.
Comment 12 Ram Chandra 2015-09-11 08:06:11 UTC
I can't reproduce this, we may have to see if a developer can figure out what's going on from the logs. 

Screencast: http://www.screencast.com/t/Dm3YsfSW4b8

Environment Info:

Microsoft Visual Studio Professional 2013
Version 12.0.31101.00 Update 4
Microsoft .NET Framework
Version 4.6.00057
Installed Version: Professional
Xamarin   3.11.857.0 (95267e5)
Xamarin.Android (72e316e4cb50a1f4238c5339a76d7c4754b85c67)
Xamarin.Forms Intellisense   1.0
Xamarin.iOS (6db87c53c073f4af2f5247fb738a27ea08c094fd)
Comment 13 dbarbin 2015-09-14 16:06:03 UTC
I ended up reinstalling literally everything on my machine (including the OS) and the current installation of Xamarin seems to be behaving correctly.  I simply couldn't wait any longer for a resolution to this.  You can close this ticket.