Bug 33578 - TableView EntryCell shows DefaultKeyboard, but after scrolling down and back a NumericKeyboard
Summary: TableView EntryCell shows DefaultKeyboard, but after scrolling down and back ...
Alias: None
Product: Forms
Classification: Xamarin
Component: Forms ()
Version: 1.5.0
Hardware: Macintosh Mac OS
: Normal major
Target Milestone: ---
Assignee: Rui Marinho
Depends on:
Reported: 2015-09-02 17:03 UTC by Andreas Klapperich
Modified: 2016-04-13 18:11 UTC (History)
6 users (show)

Tags: ac
Is this bug a regression?: ---
Last known good build:

Sample (30.14 KB, application/zip)
2015-09-02 17:03 UTC, Andreas Klapperich
Reproduction project (more simplified) (181.32 KB, application/zip)
2015-09-03 17:30 UTC, Paul DiPietro [MSFT]

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description Andreas Klapperich 2015-09-02 17:03:29 UTC
Created attachment 12724 [details]

Attached is a sample 

There are EntryCells inside a Tableview.
One with a numeric keyboard.
The first Element is a EntryCell with a default keyboard

If I click the first EntryCell at startup the default keyboard is visible.
If I move down to the EntryCell with the numeric keyboard, the numeric keyboard is visible.
If I now move to the first EntryCell than the numeric keyboard is visible.

I can not make a screencast with jing because every thing if black in the video grrrrrrrrrrrr......
Comment 1 Paul DiPietro [MSFT] 2015-09-03 02:25:19 UTC
Are you describing a particular behavior with iOS or Android? When running each, in Android, the following happens: 

1) The initial entry is tapped.
2) After scrolling to where the numeric (timeout) entry is, the standard keyboard stays open until this point.
3) The numeric keyboard pops up when the timeout entry is tapped.
4) After scrolling back up, at some point the keyboard turns into the standard one again (this seems to be approximately when the first toggle button is back in view).

In iOS, after the first entry is tapped, at no point in scrolling down to where the timeout entry is does the keyboard change. It does change to the numeric keyboard when the timeout entry is tapped, and scrolling back up to the first entry leaves the numeric keyboard on the screen. 

Based on your description, this is more in line with what iOS is doing, but more information would be helpful here to elaborate on what is expected, including any specific versions of iOS/Android or devices.
Comment 2 Andreas Klapperich 2015-09-03 15:10:13 UTC
Sorry for my bad explanation,  I try to explain it better.

The bug is only on iOS because I have no Android license.

If there is a default Keyboard for an EntryCell than I expect a default keyboard and not a numeric Keyboard

The "Timeout" is the only EntryCell with a numeric keyboard.
I installed snagit and attached is a link to a video where i played with the EntryCells.

There you can see what happens with the keyboard.


Xamarin Studio is  5.10 (build 704)

Xamarin.Forms is

IOS 8.4.1
Comment 3 Paul DiPietro [MSFT] 2015-09-03 17:29:12 UTC
I believe that I can confirm this as a bug of some sort. From what I can gather, it appears that when a table has multiple entries in it and (at least in this case) one that uses a numeric keyboard is beneath another that is an entry, and the entirety of the table requires scrolling, that shifting around between that numeric keypad into entries near the top of the window causes some odd manipulation of the type of entry.

It's difficult to explain, but when I ran it on Android there was something a little different -- if you select the first entry and scroll all the way down, you can't (at least on the Nexus 5 XAP emulator I ran it on) get to the last/numeric entry. You can if you click that numeric cell first. Beyond that the sort of weird cell manipulation going on in iOS is not apparent in Android, but the type of cell is automatically changing back and forth if you scroll.

I'm going to attach a reproduction project that is a bit simpler than the one initially provided.
Comment 4 Paul DiPietro [MSFT] 2015-09-03 17:30:25 UTC
Created attachment 12742 [details]
Reproduction project (more simplified)