Bug 33345 - Xamarin.UITest: IApp for Android cannot press the search key on a keyboard
Summary: Xamarin.UITest: IApp for Android cannot press the search key on a keyboard
Alias: None
Product: Android
Classification: Xamarin
Component: Tools and Addins ()
Version: unspecified
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: glenn.wilson
Depends on:
Reported: 2015-08-24 19:26 UTC by Dimitar Dobrev
Modified: 2015-08-27 13:51 UTC (History)
2 users (show)

Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description Dimitar Dobrev 2015-08-24 19:26:01 UTC
PressEnter() does not work. It also seems this cannot be worked around by using TapCoordinates.
Comment 1 Jonathan Pryor 2015-08-25 20:04:11 UTC
Please provide a repro project, Android version and Android device, etc.
Comment 2 Dimitar Dobrev 2015-08-26 04:26:56 UTC
Have you actually tried reproducing before asking for a project?
Comment 3 Jonathan Pryor 2015-08-26 08:32:29 UTC
app.PressUserAction() will press the default action on the keyboard (in this case the search button). PressEnter() will always do an enter.
Comment 4 Dimitar Dobrev 2015-08-26 08:39:02 UTC
This is exactly what I had in mind. However, PressUserAction is not present in Xamarin.UITest 1.0.0 (from NuGet, https://www.nuget.org/packages/Xamarin.UITest). I can see it's supposed to have been long added (http://forums.xamarin.com/discussion/28990/xamarin-uitest-0-6-7-released) but it's not there.
Comment 6 Dimitar Dobrev 2015-08-27 11:38:25 UTC
I understand, thank you. I am going to try now.
Comment 7 Dimitar Dobrev 2015-08-27 13:51:16 UTC
Glenn, this works. Thank you for your help. I am resolving this issue.