Bug 33316 - [Xamarin Studio] Hangs after "Using GTK+", fails to load addins
Summary: [Xamarin Studio] Hangs after "Using GTK+", fails to load addins
Status: RESOLVED NOT_REPRODUCIBLE
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Add-ins ()
Version: 5.9
Hardware: PC Windows
: --- normal
Target Milestone: master
Assignee: Lluis Sanchez
URL:
Depends on:
Blocks:
 
Reported: 2015-08-23 21:58 UTC by Kent Green [MSFT]
Modified: 2015-08-24 06:33 UTC (History)
1 user (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Logs from customer (17.18 KB, application/x-zip-compressed)
2015-08-23 21:58 UTC, Kent Green [MSFT]
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED NOT_REPRODUCIBLE

Description Kent Green [MSFT] 2015-08-23 21:58:53 UTC
Created attachment 12612 [details]
Logs from customer

===Overview===
From this enterprise desk case:
https://kb.xamarin.com/agent/case/194379

Customer reported Xamarin Studio was freezing when launched. Looking at the logs; only a few lines are shown, apparently freezing shortly after GTK# is loaded:

> Starting Xamarin Studio 5.9.4 (build 5)
> Running on Microsoft .NET 4.0.30319.34209
> Found GTK# version 2.12.26
> Using GTK+ 2.24.22

Customer was able to resolve the issue by deleting this cache: 
%LOCALAPPDATA%\XamarinStudio-5.0\Cache
(as described in this guide for a related scenario: https://kb.xamarin.com/customer/portal/articles/2023134)

Attaching Xamarin Studio & Visual Studio logs.
Comment 1 Lluis Sanchez 2015-08-24 06:33:34 UTC
The logs don't show any error and the problem is not happening anymore, so there isn't much we can do about it. Next time please ask the user to make a copy of the cache directory before deleting.