Bug 33294 - Older version of Xamarin on Windows cannot compile project edited with newer version of Windows
Summary: Older version of Xamarin on Windows cannot compile project edited with newer ...
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: General ()
Version: 3.11 (C5)
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Bugzilla
Depends on:
Reported: 2015-08-21 10:47 UTC by Tom Opgenorth
Modified: 2015-10-01 13:19 UTC (History)
3 users (show)

Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description Tom Opgenorth 2015-08-21 10:47:41 UTC
Background & Issue
I am setting up a CI build in Visual Studio Online (VSO) for a Xamarin project as part of research for some docs and blog posts.  I set up a simple solution with a Xamarin.Android app and a UITest project with one automated test. 

Everything works find on my local developer workstation which is a VMware Fusion image running Windows 10, Visual Studio 2015 Pro, and Xamarin 3.11.836.

When I run the build in Visual Studio Online, the build fails with the error :

2015-08-20T16:39:01.2412835Z      1>CSC : error CS1703: Multiple assemblies with equivalent identity have been imported: 'C:\Program Files (x86)\Reference Assemblies\Microsoft\Framework\MonoAndroid\v1.0\mscorlib.dll' and 'C:\Windows\Microsoft.NET\Framework\v4.0.30319\mscorlib.dll'. Remove one of the duplicate references. [C:\a\a815ee8d\phoneword\PhonewordAndroid\PhonewordAndroid.csproj]

I logged this as an issue against the VSO Agent Tasks, https://github.com/Microsoft/vso-agent-tasks/issues/439, and eventual made contact with a developer from Microsoft about this issue. The problem seems to be that VSO has a slightly older version of Xamarin installed in their images, they have Xamarin 3.11.666 (released August 5th?) installed. When Microsoft upgraded to the most recent version of Xamarin for Windows, the Xamarin.Android build task could successfully compile the project.

Currently the workaround from Microsoft is that only should fall back to the older version of Xamarin for Windows (3.11.666) as not all data centres will immediately receive the upgraded Xamarin.

Expected Results

An older version of Xamarin for Windows should be able to compile and package a Xamarin.Android project even if the .CSPROJ file was edited by a newer version of Xamarin/Visual Studio.
Comment 6 Tom Opgenorth 2015-09-23 15:35:39 UTC
Just tried this again with Xamarin 3.11.1443. It seems that the Xamarin tasks for VSO build the project just fine.

I have confirmed with Microsoft that they have not updated their VSO with a new version of Xamarin. They are still running 3.11.666.
Comment 7 Tom Opgenorth 2015-10-01 13:19:40 UTC
The problem seems to have gone away in more recent builds of Xamarin for Visual Studio (3.11.1443 or higher). Closing this issue off.