Bug 33290 - Xamarin Insights not installing when Xlabs is installed.
Summary: Xamarin Insights not installing when Xlabs is installed.
Alias: None
Product: iOS
Classification: Xamarin
Component: General ()
Version: unspecified
Hardware: PC Windows
: Normal normal
Target Milestone: Untriaged
Assignee: Bugzilla
Depends on:
Reported: 2015-08-21 03:44 UTC by frontend
Modified: 2016-06-09 01:05 UTC (History)
4 users (show)

Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description frontend 2015-08-21 03:44:18 UTC
Xamarin Insights not installing when XLabs is installed. the only way to install it is to first remove any and all references to XLabs. Then install Xamarin Insights then reinstall XLabs.

This is the error I get.
Install-Package Xamarin.Insights -Verbose -ProjectName DTApp.iOS
Attempting to gather dependencies information for package 'Xamarin.Insights.1.10.6' with respect to project targeting 'Xamarin.iOS, Version=v1.0'
Attempting to resolve dependencies for package 'Xamarin.Insights.1.10.6' with DependencyBehavior 'Lowest'
Resolving actions to install package 'Xamarin.Insights.1.10.6'
Install-Package : Already referencing a newer version of 'XLabs.Core'..
At line:1 char:1
+ Install-Package Xamarin.Insights -Verbose -ProjectName DTApp.iOS
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    + CategoryInfo          : NotSpecified: (:) [Install-Package], Exception
    + FullyQualifiedErrorId : NuGetCmdletUnhandledException,NuGet.PackageManagement.PowerShellCmdlets.InstallPackageCommand

This only happens on the iOS project.

I understand Insights is in beta, though this could be annoying for a new user wanting to add insights to an existing project.
Comment 1 Matt Ward 2015-08-21 06:11:58 UTC
Xamarin.Insights does not depend on XLabs.Core so the error message is odd.

Which version of Visual Studio are you using?

I am just wondering if this is a Visual Studio 2015 and NuGet 3 problem. I tried installing XLabs.Forms and then Xamarin.Insights into an iOS project with Visual Studio 2013 and there were no package install errors.
Comment 2 frontend 2015-08-21 07:51:21 UTC
I'm currently running Visual Studio 2015.

Though it seems like it could be only on 2015, as a colleague of mine just tried on his machine with Visual Studio 2013 and had no issues.

It's odd that it only happened for the iOS project.
Will look into it more and see if I can provide more information.
Comment 3 Matt Ward 2015-08-21 08:04:57 UTC
The NuGet team changed the package resolution logic in NuGet 3. I have seen some similar errors reported on their GitHub issues, such as:


I would update NuGet in Visual Studio to the latest version if it is not already up to date.

Other than that if you post the contents of your packages.config file which reproduces the error when you install Xamarin.Insights then I can try to reproduce it on Visual Studio 2015.
Comment 4 Sebastien Pouliot 2016-06-09 01:05:35 UTC
We have not received the requested information. If you are still experiencing this issue please provide all the requested information and re-open the bug report. Thanks!