Notice (2018-05-24): bugzilla.xamarin.com is now in
Please join us on
Visual Studio Developer Community and in the
Mono organizations on
GitHub to continue tracking issues. Bugzilla will remain
available for reference in read-only mode. We will continue to work
on open Bugzilla bugs, copy them to the new locations
as needed for follow-up, and add the new items under Related
Our sincere thanks to everyone who has contributed on this bug
tracker over the years. Thanks also for your understanding as we
make these adjustments and improvements for the future.
Please create a new report on
Developer Community or GitHub with
your current version information, steps to reproduce, and relevant error
messages or log files if you are hitting an issue that looks similar to
this resolved bug and you do not yet see a matching new report.
I know it's not our standard, but binding distributionWithLowestValue:highestValue: to "FromLowestValue" is, I think, confusing.
Agreed - any selector with a `With`  is generally best shortened (because the first parameter can be inferred from the signature and the later ones would be absent).
Now to find a better name... what about ? (open to other suggestions)
GKRandomDistribution GetValueBetween (nint lowestInclusive, nint highestInclusive);
 FromDieWithSideCount is (differently) bad because the method name and parameter both says the same thing - I'll change that one too
not a value... maybe more
> GKRandomDistribution GetDistributionBetween (nint lowestInclusive, nint
> GKRandomDistribution GetDie (nint sideCount);
as all other methods are already prefixed by `Get`.
Fixed in maccore/xcode7 5c2de6c6cbc0eaa97a0379f1da413996f721eb4f