Bug 3281 - Upgraded to 5.2 today, now Console.WriteLine no longer appears in Xcode Console
Summary: Upgraded to 5.2 today, now Console.WriteLine no longer appears in Xcode Console
Alias: None
Product: iOS
Classification: Xamarin
Component: General ()
Version: 5.2
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: Untriaged
Assignee: Rolf Bjarne Kvinge [MSFT]
Depends on:
Reported: 2012-02-08 22:57 UTC by David N. Junod
Modified: 2012-02-20 17:52 UTC (History)
3 users (show)

Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description David N. Junod 2012-02-08 22:57:40 UTC
Upgraded to 5.2 today, now Console.WriteLine no longer appears in Xcode Console.  It was all working fine up to now.
Comment 1 Rolf Bjarne Kvinge [MSFT] 2012-02-09 04:36:04 UTC
Do they appear in MonoDevelop's Application Output?
Comment 2 David N. Junod 2012-02-09 10:26:00 UTC
They did not and do not appear in MonoDevelop's Application Output.

This morning I just turned on my device and saw the output in Xcode console again.  Last night it would not appear for this device (iPhone 4S), or iPad 2 or iPhone 3G.  So something is a little flaky.  Will try to see what is different.
Comment 3 David N. Junod 2012-02-09 10:44:20 UTC
Starting with 5.2, when I Run to the device, it installs the application and immediately starts running the application.  This is new behavior.  When it does this, I get no Console.WriteLine output appearing any where.

If I kill that process and start it manually, then I get my Console.WriteLine appearing in Xcode Console.
Comment 4 Rolf Bjarne Kvinge [MSFT] 2012-02-09 18:17:17 UTC
You should at least get Console.WriteLines in the Application Output in MonoDevelop - does this only happen for one specific project, or for any project you create? Do you get anything at all in the Application Output?
Comment 5 David N. Junod 2012-02-09 19:43:31 UTC
I don't and never have gotten output in the Application Output area when running on any iOS device.  I always had to bring up Xcode Console to see it.  Now I don't even get that, unless I exit from debug and start it back up.  This new behavior of no Xcode Console output started yesterday when I did the upgrade to 5.2
Comment 6 Rolf Bjarne Kvinge [MSFT] 2012-02-10 07:28:25 UTC
Is this happening when you run both with and without debugging?
Comment 7 Rolf Bjarne Kvinge [MSFT] 2012-02-14 05:24:59 UTC
I can reproduce this when I run without debugging.
Comment 8 Dean Herbert 2012-02-15 02:04:02 UTC
I can reproduce this when running with or without debugging. Using latest version of all components on the beta stream.
Comment 9 Rolf Bjarne Kvinge [MSFT] 2012-02-20 17:52:20 UTC
Fixed (md-addins: c8d6809e).

The fix will likely be in the next MonoDevelop update.