Bug 32787 - build doesn't take care of modified file
Summary: build doesn't take care of modified file
Status: RESOLVED NOT_REPRODUCIBLE
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: General ()
Version: unspecified
Hardware: Macintosh Mac OS
: Normal normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2015-08-05 06:00 UTC by renan jegouzo
Modified: 2017-05-15 23:55 UTC (History)
4 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED NOT_REPRODUCIBLE

Description renan jegouzo 2015-08-05 06:00:58 UTC
when I modify a source file in a library (debug mode),
the code isn't included when I make a build, 
I need to clean all/ rebuild all each time to get the code included
it's fairly exhausting..

Xamarin Studio
Version 5.9.4 (build 5)
Installation UUID: 2a46676f-5eb8-4569-9aa7-630cd15bdfc2
Runtime:
	Mono 4.0.2 ((detached/c99aa0c)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 400020005

Apple Developer Tools
Xcode 6.4 (7720)
Build 6E35b

Xamarin.Mac
Version: 2.0.2.35 (Business Edition)

Build Information
Release ID: 509040005
Git revision: 8010a90f6e246b32364e3fb46ef2c9d1be9c9a2b
Build date: 2015-06-08 16:52:06-04
Xamarin addins: 7e93e9c3503f28770f23ce1b7eafd829919f18e8

Operating System
Mac OS X 10.10.4
Darwin macbook.home 14.4.0 Darwin Kernel Version 14.4.0
    Thu May 28 11:35:04 PDT 2015
    root:xnu-2782.30.5~1/RELEASE_X86_64 x86_64
Comment 1 Rajneesh Kumar 2015-08-21 11:44:10 UTC
Hi, I tried to reproduce this issue but not able to reproduce because I am not sure about the steps. However I have tried it and created a sample application. I have attached sample link with this bug, please have a look on it.

Sample URL: https://www.dropbox.com/s/9r7j3f0motu2j7s/BugTest_32787.zip?dl=0

Screencast: http://www.screencast.com/t/in35Liwy1

Could you please provide me proper steps or a sample application that demonstrate this issue. That would be very helpful to reproduce this issue at our end.

Thanks..!


Environment Info:

=== Xamarin Studio ===

Version 5.9.5 (build 9)
Installation UUID: 011d70a5-dede-428b-ab04-ef451c2e539d
Runtime:
	Mono 4.0.3 ((detached/d6946b4)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 400030020

=== Xamarin.Android ===

Version: 5.1.5.3 (Enterprise Edition)
Android SDK: /Users/MM/Desktop/android-sdk-macosx
	Supported Android versions:
		2.3    (API level 10)
		4.0.3  (API level 15)
		4.1    (API level 16)
		4.2    (API level 17)
		4.3    (API level 18)
		4.4    (API level 19)
		4.4.87 (API level 20)
		5.0    (API level 21)
		5.1    (API level 22)
Java SDK: /usr
java version "1.7.0_65"
Java(TM) SE Runtime Environment (build 1.7.0_65-b17)
Java HotSpot(TM) 64-Bit Server VM (build 24.65-b04, mixed mode)

=== Xamarin Android Player ===

Version: Unknown version
Location: /Applications/Xamarin Android Player.app

=== Apple Developer Tools ===

Xcode 6.2 (6776)
Build 6C131e

=== Xamarin.iOS ===

Version: 8.10.4.51 (Enterprise Edition)
Hash: 838ae98
Branch: master
Build date: 2015-08-10 13:03:59-0400

=== Xamarin.Mac ===

Version: 2.0.2.126 (Business Edition)

=== Build Information ===

Release ID: 509050009
Git revision: b99cb19a1d3b15d8980c4616f13f837457e5b292
Build date: 2015-07-28 02:01:44-04
Xamarin addins: d53d6eceb828422f3d4aff8547f2f6bab6c9ea58

=== Operating System ===

Mac OS X 10.9.5
Darwin MacMini.local 13.4.0 Darwin Kernel Version 13.4.0
    Sun Aug 17 19:50:11 PDT 2014
    root:xnu-2422.115.4~1/RELEASE_X86_64 x86_64
Comment 2 renan jegouzo 2015-12-15 08:23:12 UTC
in fact it's in monodevelop if you edit a file in a dependency library without saving, and press "run" the program is launched without a rebuild, I have this on OSX and linux.
Comment 3 renan jegouzo 2015-12-15 08:45:40 UTC
for android, ios, osx, linux projects
Comment 4 Chris Hamons 2015-12-15 14:35:52 UTC
So a few things.

a) This ins't a Xamarin.Mac issue. Xamarin.Mac is the binding to Cocoa to write desktop OS X applications.
b) Have you checked your "File Save Options Before Building"? It's under the preferences -> projects -> build section in your mlnodevelop preferences. One of the options is to save open documents before building
c) I believe MonoDevelop does separate building from running, unlike Visual Studio.

Could you please attach an example project showing the behavior you think is wrong and/or detailed steps to reproduce.
Comment 5 renan jegouzo 2016-02-16 06:51:56 UTC
what i was saying is the opposite If I save the file, and build the library only (command+b), when I run the program (play button), it runs with the old library version.
Comment 6 renan jegouzo 2016-02-16 06:55:01 UTC
maybe linked to this bug:
https://bugzilla.xamarin.com/show_bug.cgi?id=38635
or this one:
https://bugzilla.xamarin.com/show_bug.cgi?id=38244
Comment 7 Lluis Sanchez 2016-02-17 14:26:02 UTC
We can't reproduce the problem. We need a sample project which can be used to verify the issue.
Comment 8 Kirill Osenkov 2017-05-15 23:55:46 UTC
We're resolving as not reproducible, but please feel free to reactivate if you have more information for us. Thanks.