Bug 32694 - F# addin chews up infix fn symbols
Summary: F# addin chews up infix fn symbols
Status: RESOLVED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: F# Add-in ()
Version: 5.9
Hardware: PC Mac OS
: Normal normal
Target Milestone: master
Assignee: Dave Thomas
URL:
Depends on:
Blocks:
 
Reported: 2015-08-02 11:51 UTC by henrik
Modified: 2016-05-09 09:13 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
a (22.59 KB, image/png)
2015-08-02 11:51 UTC, henrik
Details
b (18.87 KB, image/png)
2015-08-02 11:51 UTC, henrik
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description henrik 2015-08-02 11:51:21 UTC
Created attachment 12330 [details]
a

Repro:

 1. New fsx
 2. Type `let (<.>) a = ()`
 3. Select `<` and type `>`.

The stuff up to the `)` disappears.
Comment 1 henrik 2015-08-02 11:51:34 UTC
Created attachment 12331 [details]
b
Comment 2 henrik 2015-08-02 11:55:11 UTC
Another thing:

After the repro, the buffer still contains the chars, but doesn't show them.

Now go ahead and write `>.` and then `>`. After this, `>.` disappears, and you're left with `>`.
Comment 3 Dave Thomas 2015-08-04 07:03:18 UTC
Also, no tooltip
Comment 4 Dave Thomas 2015-10-08 11:20:45 UTC
The buffer problem no longer occurs in the preview release.

Tooltips are still a problem *if* type resolution has not completed due to nuget references not being retrieved etc.
Comment 5 henrik 2016-05-09 09:13:14 UTC
Not an issue anymore.