Bug 32692 - can't build in release xam mac app
Summary: can't build in release xam mac app
Alias: None
Product: Xamarin.Mac
Classification: Desktop
Component: Other ()
Version: 2.0.0
Hardware: Macintosh Mac OS
: Normal normal
Target Milestone: ---
Assignee: Chris Hamons
Depends on:
Reported: 2015-08-02 03:51 UTC by renan jegouzo
Modified: 2015-12-15 10:23 UTC (History)
6 users (show)

Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description renan jegouzo 2015-08-02 03:51:00 UTC
I have installed xamarin.mac few days ago, all was working, and since the last update it fails at building in release mode. all still OK in debug mode.

here the log:

Updating application manifest

Merging Mono Runtime into app bundle
/Library/Frameworks/Xamarin.Mac.framework/Versions/Current/bin/mmp -linksdkonly "-minos=10.6" --sdkroot "/Applications/Xcode.app/Contents/Developer" -o "/Users/renanyoy/git/aestesis-mono/aestesis/WavesOSX/bin/Release" -n "WavesOSX" --profile "4.5" -a "/Users/renanyoy/git/aestesis-mono/alibs/AlibMac/bin/Release/AlibMac2.dll" -a "/Users/renanyoy/git/aestesis-mono/_libs/System.Json/src/System.Json/bin/Release/System.Json.dll" -a "/Users/renanyoy/git/aestesis-mono/_libs/OpenTK/Binaries/OpenTK/Release/OpenTK.dll" -a "/Library/Frameworks/Mono.framework/Versions/4.0.2/lib/mono/4.5/System.dll" -a "/Library/Frameworks/Mono.framework/Versions/4.0.2/lib/mono/4.5/System.Xml.dll" -a "/Library/Frameworks/Mono.framework/Versions/4.0.2/lib/mono/4.5/System.Core.dll" -a "/Library/Frameworks/Mono.framework/Versions/4.0.2/lib/mono/4.5/System.Xml.Linq.dll" -a "/Library/Frameworks/Mono.framework/Versions/4.0.2/lib/mono/4.5/System.Drawing.dll" -a "/Library/Frameworks/Xamarin.Mac.framework/Versions/Current/lib/mono/XamMac.dll" -a "/Library/Frameworks/Mono.framework/Versions/4.0.2/lib/mono/4.5/System.Core.dll" "/Users/renanyoy/git/aestesis-mono/aestesis/WavesOSX/bin/Release/WavesOSX.exe"
Xamarin.Mac 2.0.2 Business Edition
error MM2001: Could not link assemblies. Reason: Argument is out of range.

Xamarin Studio
Version 5.9.4 (build 5)
Installation UUID: 2a46676f-5eb8-4569-9aa7-630cd15bdfc2
	Mono 4.0.2 ((detached/c99aa0c)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 400020005

Apple Developer Tools
Xcode 6.4 (7720)
Build 6E35b

Version: (Business Edition)

Build Information
Release ID: 509040005
Git revision: 8010a90f6e246b32364e3fb46ef2c9d1be9c9a2b
Build date: 2015-06-08 16:52:06-04
Xamarin addins: 7e93e9c3503f28770f23ce1b7eafd829919f18e8

Operating System
Mac OS X 10.10.4
Darwin macbook.home 14.4.0 Darwin Kernel Version 14.4.0
    Thu May 28 11:35:04 PDT 2015
    root:xnu-2782.30.5~1/RELEASE_X86_64 x86_64
Comment 1 Rajneesh Kumar 2015-08-06 08:49:12 UTC
Hi Renan, 
I have tried to reproduce this issue but not able to reproduce this. I am able to build the XamarinMac application in release mode successfully.

Screencast: http://www.screencast.com/t/lRanHpr7F

Could you please provide us a small sample application that demonstrate this issue, or proper steps to reproduce this. That would very helpful to reproduce this issue at our end.


Environment Info:

=== Xamarin Studio ===

Version 5.9.5 (build 9)
Installation UUID: 011d70a5-dede-428b-ab04-ef451c2e539d
	Mono 4.0.3 ((detached/d6946b4)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 400030020

=== Xamarin.Android ===

Version: (Business Edition)
Android SDK: /Users/MM/Desktop/android-sdk-macosx
	Supported Android versions:
		2.3    (API level 10)
		4.0.3  (API level 15)
		4.1    (API level 16)
		4.2    (API level 17)
		4.3    (API level 18)
		4.4    (API level 19)
		4.4.87 (API level 20)
		5.0    (API level 21)
Java SDK: /usr
java version "1.7.0_65"
Java(TM) SE Runtime Environment (build 1.7.0_65-b17)
Java HotSpot(TM) 64-Bit Server VM (build 24.65-b04, mixed mode)

=== Xamarin Android Player ===

Version: Unknown version
Location: /Applications/Xamarin Android Player.app

=== Apple Developer Tools ===

Xcode 6.2 (6776)
Build 6C131e

=== Xamarin.iOS ===

Version: (Business Edition)
Hash: 2c66d2f
Branch: master
Build date: 2015-08-04 13:52:25-0400

=== Xamarin.Mac ===

Version: (Business Edition)

=== Build Information ===

Release ID: 509050009
Git revision: b99cb19a1d3b15d8980c4616f13f837457e5b292
Build date: 2015-07-28 02:01:44-04
Xamarin addins: d53d6eceb828422f3d4aff8547f2f6bab6c9ea58

=== Operating System ===

Mac OS X 10.9.5
Darwin MacMini.local 13.4.0 Darwin Kernel Version 13.4.0
    Sun Aug 17 19:50:11 PDT 2014
    root:xnu-2422.115.4~1/RELEASE_X86_64 x86_64
Comment 2 renan jegouzo 2015-08-08 17:15:44 UTC
I think you need to try a link of 50 assemblies.. or more..
Comment 3 renan jegouzo 2015-08-09 06:44:15 UTC
the major bug is the error message itself.
it should help the xamarin user to find what is wrong, and get direction on how to fix it.
but unfortunately this message means nothing, and doesn't help.
Comment 4 Rolf Bjarne Kvinge [MSFT] 2015-08-10 04:08:05 UTC
@renan, I agree the error message isn't helpful, and we'll improve it once we can reproduce the problem ourselves, but this seems specific to your app, so could you zip up your project and attach it so that we can have a look at it?
Comment 5 renan jegouzo 2015-08-11 05:03:33 UTC
I think I found a lead, my mac projects have been made with monomac, and I switched with xamarin.mac. I need to create new  projects. as your last updates does't work with projects from last year..
Comment 6 renan jegouzo 2015-08-11 05:04:31 UTC
as usual big waste of time at using xamarin... :/
Comment 7 renan jegouzo 2015-08-11 06:18:42 UTC
I'm trying to create a new project, but I can't confirm it works cause of that https://bugzilla.xamarin.com/show_bug.cgi?id=32948
Comment 8 renan jegouzo 2015-08-11 08:52:04 UTC
I porting all my project for new xamarin mac, takes time..
the problem here was that using xammac, it's not possible anymore to build in release mode.
maybe the problem is solved using xamarin.mac etc..
but for the open source guys, it can be a problem if they can't build in release mode using the open source version..
Comment 9 renan jegouzo 2015-08-11 10:01:33 UTC
it's ok, release build working with xamarin.mac mobile framework
Comment 10 renan jegouzo 2015-12-15 08:48:45 UTC
Comment 11 Rajneesh Kumar 2015-12-15 10:23:05 UTC
Thanks @Renan for the verification of issue.

So as per comment 9, it's ok, release build working with xamarin.mac mobile framework. Hence I am closing this issue.