Bug 32595 - CNContainer.Type might be better named CNContainer.ContainerType
Summary: CNContainer.Type might be better named CNContainer.ContainerType
Alias: None
Product: iOS
Classification: Xamarin
Component: Xamarin.iOS.dll ()
Version: XI 8.99 (iOS9 previews)
Hardware: PC Mac OS
: --- normal
Target Milestone: Untriaged
Assignee: Bugzilla
Depends on:
Reported: 2015-07-29 21:06 UTC by Larry O'Brien
Modified: 2015-07-29 21:46 UTC (History)
2 users (show)

Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description Larry O'Brien 2015-07-29 21:06:28 UTC
The CNContainer.Type property is of type CNContainerType. I think we typically rename Type properties so they aren't confused with .NET Type -- for instance CNContact.ContactType.
Comment 1 Sebastien Pouliot 2015-07-29 21:46:26 UTC
Agreed, `Type` is too general and potentially confusing.

maccore/xcode7 43ba1f3a3b70e0a2bb2659451f2687f0cea498d3