Bug 324 - Default.png
Summary: Default.png
Alias: None
Product: iOS
Classification: Xamarin
Component: General ()
Version: 4.x
Hardware: Macintosh Mac OS
: --- major
Target Milestone: Untriaged
Assignee: Jeffrey Stedfast
Depends on:
Reported: 2011-08-18 15:55 UTC by Hipolyto
Modified: 2011-08-23 17:31 UTC (History)
3 users (show)

Is this bug a regression?: ---
Last known good build:

example (4.13 MB, application/zip)
2011-08-18 15:55 UTC, Hipolyto
rename image (4.10 MB, application/zip)
2011-08-23 16:49 UTC, Hipolyto

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description Hipolyto 2011-08-18 15:55:13 UTC
Created attachment 151 [details]

Hello everyone,

My problem is as follows:

default.png, looks good in the simulator, but in the device not seen.

any ideas?

MonoDevelop 2.4.2 Monotoucn

Comment 1 Miguel de Icaza [MSFT] 2011-08-18 18:41:18 UTC
What version of MonoDevelop are you using?
Comment 2 Mikayla Hutchinson [MSFT] 2011-08-18 19:14:31 UTC
Can you verify that Default.png is present in the app bundle when compiled for device? The only difference between simulator and device builds should be MD uses Apple's pngcrush tool to optimize the images for the device.
Comment 3 Hipolyto 2011-08-18 20:13:28 UTC
the current version is: 2.6 RC1.
Comment 4 Miguel de Icaza [MSFT] 2011-08-19 21:21:25 UTC
We just released 2.6 RC2 with a fix for this problem.

Can you please try it out?
Comment 5 Hipolyto 2011-08-19 22:05:47 UTC

thanks, I'll try.
Comment 6 Hipolyto 2011-08-19 22:16:56 UTC
Conduct the test and did not work.

Monodevelop: 2.6 RC2

What could be missing?
Comment 7 Miguel de Icaza [MSFT] 2011-08-19 23:05:38 UTC
If you look up the properties for the Default.png file, does it say "Content"?
Comment 8 Hipolyto 2011-08-20 02:24:39 UTC
yes, it said content.

Delete the image of the project and add it again.

still not working.



si, dice contenido.

Elimine la imagen del proyecto y lo volvi a agregar.

sigue sin funcionar.

Comment 9 Hipolyto 2011-08-23 12:58:43 UTC
any news of this?

Comment 10 Jeffrey Stedfast 2011-08-23 16:14:52 UTC

Unlike MacOS X, the iOS is has a case-sensitive file system.   This means that 'default.png' is not the same as 'Default.png'.   When you added 'default.png' as Content, it happened to work on MacOS X and the Simulator, because you are really running on OSX.

The device does not get this benefit.   The fix is to rename your "default.png" to "Default.png".   Remove it from your solution, rename the file on disk, and add it back, and make sure it is flagged as "Content".
Comment 11 Jeffrey Stedfast 2011-08-23 16:21:27 UTC
I've filed a new bug (bug #70) as a feature request to rename these files automatically.
Comment 12 Jeffrey Stedfast 2011-08-23 16:21:51 UTC
er, that should say bug #370
Comment 13 Hipolyto 2011-08-23 16:49:08 UTC
Created attachment 172 [details]
rename image


Delete the file, I renamed it, then add it again.

The image is not added to the device.

Added example.

Please help!
Comment 14 Jeffrey Stedfast 2011-08-23 17:05:56 UTC
Just tested your zip, didn't change anything, did Build -> Rebuild All, then did Run -> Upload to Device, then ran it on the device and the Default.png loaded just fine.

Did you forget to rebuild the project and/or forget to upload the newly built package to the device?
Comment 15 Hipolyto 2011-08-23 17:31:27 UTC
It worked perfectly.

Thank you very much!