Bug 32154 - __res_name_case_map.txt not found
Summary: __res_name_case_map.txt not found
Alias: None
Product: Android
Classification: Xamarin
Component: MSBuild ()
Version: 5.2
Hardware: PC Windows
: Normal normal
Target Milestone: ---
Assignee: dean.ellis
Depends on:
Reported: 2015-07-20 14:08 UTC by jonathan_chapman
Modified: 2017-10-04 16:11 UTC (History)
5 users (show)

Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description jonathan_chapman 2015-07-20 14:08:12 UTC
I just created a clean machine, did all the installs (3.11.666), and then tried to build a project that was previously building before I had to rebuild the machine.  Now I get the below error.  The project is a large project that includes Xamarin Forms. 

C:\Program Files (x86)\MSBuild\Xamarin\Android\Xamarin.Android.Common.targets(828,2): monodroid error XA0000: Unexpected error - Please file a bug report at http://bugzilla.xamarin.com. Reason: System.IO.DirectoryNotFoundException: Could not find a part of the path "C:\<Project Location>\ProjectShared.Droid\obj\Debug\__library_projects__\<Library Project>\library_project_imports\__res_name_case_map.txt"
Comment 1 jonathan_chapman 2015-07-20 14:32:33 UTC
Looks like the actual folder has "__AndroidLibraryProjects__" before the "__library_projects__".  There is a "__library_projects__" at the correct level but it's empty.
Comment 2 dean.ellis 2015-07-22 03:33:39 UTC
Hi Jonathan

any chance you can provide us with the full diagnostic build output? [1] It would help us track down the issue. I assume the <LibraryProject> is just a plain Android Library Project Type which contains Resources such as layout items etc. I will try to replicate this issue here in the mean time.

[1] http://developer.xamarin.com/guides/android/troubleshooting/troubleshooting/
Comment 4 eamr 2015-08-27 11:27:59 UTC
I encountered the same error. When I drilled down as far as I could go following the path in the error message, I find _AndroidLibraryProjects_.zip

I believe this is unzipped during the build process. The zip file contains the desired files and directories that could not be found.

Trying to unzip, using Windows zip tool, the following message is received

"The file name(s) would be too long for the destination folder. You can shorten the file name and try again, or try a location that has a shorter path."

Unzipping with 7Zip, creates a empty file as the error occurs silently, which I believe is the same thing that happens in the Build Process.

My company has brought this issue up with Xamarin and we've been told to map our projects to drive directories. This shortens the directory path and solved the problem.
Comment 5 jzeferino 2016-12-10 18:40:52 UTC
Ended up in the same situation and I can confirm what @eamr told.
I moved the project to the drive folder and it worked.
Comment 6 Jon Douglas [MSFT] 2017-10-04 16:11:23 UTC
Thank you for taking the time to submit this report. After reviewing the description of this bug, we believe it no longer affects the current version of Xamarin.Android. If you are still experiencing the issue after updating your packages, please reopen this report with an attached reproduction.