Bug 32128 - Strange Mono behaviour on Win 8.1
Summary: Strange Mono behaviour on Win 8.1
Status: NEW
Alias: None
Product: Class Libraries
Classification: Mono
Component: System ()
Version: 4.0.0
Hardware: PC Windows
: --- normal
Target Milestone: Untriaged
Assignee: Bugzilla
Depends on:
Reported: 2015-07-20 03:46 UTC by Alex
Modified: 2016-11-03 12:09 UTC (History)
5 users (show)

Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report for Bug 32128 on GitHub or Developer Community if you have new information to add and do not yet see a matching new report.

If the latest results still closely match this report, you can use the original description:

  • Export the original title and description: GitHub Markdown or Developer Community HTML
  • Copy the title and description into the new report. Adjust them to be up-to-date if needed.
  • Add your new information.

In special cases on GitHub you might also want the comments: GitHub Markdown with public comments

Related Links:

Description Alex 2015-07-20 03:46:55 UTC
I tried to use Mono 4.0 runtime on Windows 8.1. My app contains NancyFx (https://github.com/NancyFx/Nancy), a framework for building REST services. When I run my test app on windows with nancy self-hosting and MS .Net framework, it works really good. But, when executed with mono (on windows also), it lacks performance and gives me a little strange responses.

For example, for a simple method like below:

Get["/IsActive"] = param =>
                var json = Response.AsJson(true);
                return json;
I get simply true in .net execution and

P/1.1 200 OK
Content-Type: application/json; charset=utf-8
Server: Mono-HTTPAPI/1.0
Date: Mon, 13 Jul 2015 18:05:24 GMT
Transfer-Encoding: chunked
Keep-Alive: timeout=15,max=100

and on mono I get this response really slow. I guess it's some mono issues with HttpHandler or something...

To reproduce this bug simply create Nancy self-hosted app with the registration below (you can find examples on Nancy github page) and try to consume it.
Comment 1 Marek Safar 2015-07-20 07:57:15 UTC
Please provide self contained repro for your issue
Comment 2 Seth Wenzel 2015-07-26 14:55:12 UTC
This was already reported in Bug 30065.  That bug has an attached solution that shows the problem.
Comment 3 Seth Wenzel 2015-07-26 15:03:22 UTC
Also, we see this with both Nancy and WebAPI.  Bug 30065 reproduced it by using OWIN middleware without a framework like WebAPI or Nancy.
Comment 4 David Stahl 2015-09-05 20:04:11 UTC
Is there any update?

I left a comment on BUG 30065 as well and I can post another self-contained reproduction if requested.
Comment 5 Marek Safar 2016-04-16 09:33:00 UTC
Comment 6 ColmanJ 2016-11-03 12:09:41 UTC
Is there any news about this problem? I'm using mono x64 and there the problem still exists