Bug 32047 - Multiple Solutions in a Workspace will only restore the last added solution's packages
Summary: Multiple Solutions in a Workspace will only restore the last added solution's...
Status: RESOLVED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: NuGet ()
Version: 5.9
Hardware: PC All
: Normal normal
Target Milestone: master
Assignee: Matt Ward
URL:
Depends on:
Blocks:
 
Reported: 2015-07-16 16:21 UTC by Jon Douglas [MSFT]
Modified: 2016-02-25 10:43 UTC (History)
4 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Jon Douglas [MSFT] 2015-07-16 16:21:46 UTC
*Description

When adding a solution to a workspace in Xamarin Studio, the functionality to restore nuget packages works just fine for one solution. However when adding multiple solutions to a workspace, it only will restore the last listed solution's nuget packages. Take the following example:

FAILURE REPRO:

1. Add three solutions containing NuGet package references to a workspace named Workspace1(You can use whichever project template you'd like)
2. Navigate to the solution directory using Finder and delete the entire packages/ folder for each respective solution
3. Open Workspace1, right-click the solution, and select Restore NuGet Packages (notice that it appears to do some restore work)
4. Navigate back to the solution directory and notice the packages/ folder has not been recreated for every solution but only the last

i.e.

<WorkspaceItem ctype="Workspace">
<Items>
<Item>../../Solution1.sln</Item>
<Item>../../Solution2.sln</Item>
<Item>../../Solution3.sln</Item>
</Items>
</WorkspaceItem>

Will only restore NuGet packages for the "Solution3.sln" project. You can also confirm this by looking in Finder at the respective folder.


WORKING REPRO:

1. Open just the solution from the above example (not the workspace)
2. Right-click the solution, and select Restore NuGet Packages
3. Navigate back to the solution directory and notice the packages/ folder has been successfully recreated

*Version Information

Xamarin Studio 5.9.4
Comment 1 Manish Sinha 2015-07-20 11:33:37 UTC
I managed to reproduce it with Version 5.10 (build 413) from master

Also the same behavior with Update Packages rather than restore

http://screencast.com/t/CZJdfOHsBU9

Jon was able to reproduce it on Windows, I am also able to reproduce it on Mac
Comment 2 xamarin-release-manager 2016-02-25 10:05:53 UTC
Fixed in version 6.1.0.50 (master)

Author: Matt Ward
Commit: 9aefb99de50d373334167a6c531cd9b97a1a31c1 (mono/monodevelop)
Comment 3 xamarin-release-manager 2016-02-25 10:43:22 UTC
Fixed in version 6.0.0.4623 (cycle7)

Author: Matt Ward
Commit: 41da704bb244b1fa9cc57519d5a563d14c000899 (mono/monodevelop)