Bug 3201 - Infinite loop when adding gnome-sharp reference to project
Summary: Infinite loop when adding gnome-sharp reference to project
Status: NEW
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Project Management ()
Version: 2.8.6
Hardware: PC Windows
: Normal normal
Target Milestone: ---
Assignee: Bugzilla
Depends on:
Reported: 2012-02-02 11:35 UTC by Chris Howie
Modified: 2015-08-20 13:26 UTC (History)
3 users (show)

Is this bug a regression?: ---
Last known good build:

Test project that makes MD hang (5.95 KB, application/octet-stream)
2013-01-19 14:03 UTC, Bohdan Trotsenko

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report for Bug 3201 on Developer Community or GitHub if you have new information to add and do not yet see a matching new report.

If the latest results still closely match this report, you can use the original description:

  • Export the original title and description: Developer Community HTML or GitHub Markdown
  • Copy the title and description into the new report. Adjust them to be up-to-date if needed.
  • Add your new information.

In special cases on GitHub you might also want the comments: GitHub Markdown with public comments

Related Links:

Description Chris Howie 2012-02-02 11:35:27 UTC
When I attempt to add a reference to gnome-sharp to my project, MD enters an infinite loop.  This also happens consistently when I open the Stetic designer if gnome-sharp is a reference.

If I remove the gnome-sharp reference prior to opening the designer, I don't have this problem.

This is on MD, built from the Git tag.

kill -QUIT spits out:

... MonoDevelop.GtkCore.GuiBuilder.GuiBuilderProject.OnReferenceAdded (object,MonoDevelop.Projects.ProjectReferenceEventArgs) [0x00036] in /home/chris/src/monodevelop/main/src/addins/MonoDevelop.GtkCore/MonoDevelop.GtkCore.GuiBuilder/GuiBuilderProject.cs:376
  at (wrapper delegate-invoke) <Module>.invoke_void__this___object_ProjectReferenceEventArgs (object,MonoDevelop.Projects.ProjectReferenceEventArgs) <IL 0x00059, 0xffffffff>
  at MonoDevelop.Projects.DotNetProject.OnReferenceAddedToProject (MonoDevelop.Projects.ProjectReferenceEventArgs) [0x0000b] in /home/chris/src/monodevelop/main/src/core/MonoDevelop.Core/MonoDevelop.Projects/DotNetProject.cs:1108
  at MonoDevelop.Projects.DotNetProject.NotifyReferenceAddedToProject (MonoDevelop.Projects.ProjectReference) [0x00012] in /home/chris/src/monodevelop/main/src/core/MonoDevelop.Core/MonoDevelop.Projects/DotNetProject.cs:1095
  at MonoDevelop.Projects.DotNetProject.OnItemsAdded (System.Collections.Generic.IEnumerable`1<MonoDevelop.Projects.ProjectItem>) [0x00026] in /home/chris/src/monodevelop/main/src/core/MonoDevelop.Core/MonoDevelop.Projects/DotNetProject.cs:1071
  at MonoDevelop.Projects.ProjectItemCollection`1.NotifyAdded (System.Collections.Generic.IEnumerable`1<MonoDevelop.Projects.ProjectItem>,bool) [0x0009a] in /home/chris/src/monodevelop/main/src/core/MonoDevelop.Core/MonoDevelop.Projects/ProjectItemCollection.cs:153
  at MonoDevelop.Projects.ProjectItemCollection`1.MonoDevelop.Projects.IItemListHandler.InternalAdd (System.Collections.Generic.IEnumerable`1<MonoDevelop.Projects.ProjectItem>,bool) [0x00041] in /home/chris/src/monodevelop/main/src/core/MonoDevelop.Core/MonoDevelop.Projects/ProjectItemCollection.cs:127
  at MonoDevelop.Projects.ProjectItemCollection`1.NotifyAdded (System.Collections.Generic.IEnumerable`1<MonoDevelop.Projects.ProjectItem>,bool) [0x00082] in /home/chris/src/monodevelop/main/src/core/MonoDevelop.Core/MonoDevelop.Projects/ProjectItemCollection.cs:151
  at MonoDevelop.Projects.ProjectItemCollection`1.OnItemAdded (T) [0x00017] in /home/chris/src/monodevelop/main/src/core/MonoDevelop.Core/MonoDevelop.Projects/ProjectItemCollection.cs:113
  at MonoDevelop.Projects.ItemCollection`1.InsertItem (int,T) [0x00008] in /home/chris/src/monodevelop/main/src/core/MonoDevelop.Core/MonoDevelop.Projects/ItemCollection.cs:39
  at System.Collections.ObjectModel.Collection`1.Add (T) [0x0000c] in /home/chris/src/mono/mcs/class/corlib/System.Collections.ObjectModel/Collection.cs:74
  at MonoDevelop.GtkCore.ReferenceManager.Update (string) [0x00116] in /home/chris/src/monodevelop/main/src/addins/MonoDevelop.GtkCore/MonoDevelop.GtkCore/ReferenceManager.cs:159
  at MonoDevelop.GtkCore.ReferenceManager.Update () [0x00000] in /home/chris/src/monodevelop/main/src/addins/MonoDevelop.GtkCore/MonoDevelop.GtkCore/ReferenceManager.cs:126
  at MonoDevelop.GtkCore.GtkDesignInfo.UpdateGtkFolder () [0x0019f] in /home/chris/src/monodevelop/main/src/addins/MonoDevelop.GtkCore/MonoDevelop.GtkCore/GtkDesignInfo.cs:313
  at MonoDevelop.GtkCore.GuiBuilder.GuiBuilderProject.Save (bool) [0x00064] in /home/chris/src/monodevelop/main/src/addins/MonoDevelop.GtkCore/MonoDevelop.GtkCore.GuiBuilder/GuiBuilderProject.cs:205
  at MonoDevelop.GtkCore.GuiBuilder.GuiBuilderProject.OnReferenceAdded (object,MonoDevelop.Projects.ProjectReferenceEventArgs) [0x00036] in /home/chris/src/monodevelop/main/src/addins/MonoDevelop.GtkCore/MonoDevelop.GtkCore.GuiBuilder/GuiBuilderProject.cs:376
Comment 1 Bohdan Trotsenko 2013-01-19 14:00:51 UTC
I've also found this when adding a reference to gnome-sharp v. to my project.

Basically I wanted to show files' thumbnails.

I made the simplest app to display a thumbnail (https://dl.dropbox.com/u/6656474/test2.tar.bz2),
but monodevelop hangs when I click 'Ok'.
Screenshot: https://dl.dropbox.com/u/6656474/Screenshot%20from%202013-01-19%2017%3A57%3A47.png
Tried on monodevelop,, 3.0.6, 3.1 (just cloned and compiled) on Ubuntu 12.04 64bit
$ uname -a
Linux xps17-ubuntu 3.2.0-36-generic #57-Ubuntu SMP Tue Jan 8 21:44:52 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux
and on monodevelop on Ubuntu 12.04 32bit

It consumes all the available CPU then, I guess it's in an infinite loop.
UI thread is unresponsive.

I tried to trick it. I created a new solution, added a reference to gnome-sharp – fine.
Then, with vim I copied the <Reference ...></...> section to the original solution.
In this case, it either hangs when compliling, or hangs or crashes trying to display UI with stetic.
Comment 2 Bohdan Trotsenko 2013-01-19 14:03:41 UTC
Created attachment 3241 [details]
Test project that makes MD hang