Bug 31963 - UI glitchets when using Searchbar with the listview
Summary: UI glitchets when using Searchbar with the listview
Alias: None
Product: Forms
Classification: Xamarin
Component: iOS ()
Version: 1.4.3
Hardware: PC Mac OS
: --- normal
Target Milestone: ---
Assignee: Bugzilla
Depends on:
Reported: 2015-07-15 03:07 UTC by Prashant Cholachagudda
Modified: 2016-04-11 07:00 UTC (History)
3 users (show)

Tags: ac
Is this bug a regression?: ---
Last known good build:

Testcase (5.92 KB, application/octet-stream)
2015-07-15 03:07 UTC, Prashant Cholachagudda
Reproduction (178.95 KB, application/zip)
2015-07-31 14:05 UTC, Chris King

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description Prashant Cholachagudda 2015-07-15 03:07:33 UTC
Created attachment 12032 [details]

I have a SearchBar and a Listview, If you remove the search bar everything
work fine. So problem is in relation with the searchbar.

1- ProgressIndicator is not showing when SearchBar is in entry mode. Enter
any text and press search and you will not see any progress indicator.

2- PullToRefresh is not working when SearchBar is in entry mode. If you
press "Cancel" on the searchbar PullToRefresh is working and progress is

3- When SearchBar is in edit mode, scroll list and you will see item-1
going under the searchbar.

If you add "searchBar.Unfocus();" in SearchButtonPressed event the problem
in 95% resolved except for the first load of the list where the progress
indicator is still not showing.

Screencast: https://www.dropbox.com/s/nplmr1zaj8pyqit/VideoXamarinBug.mp4?dl=0
Comment 1 Chris King 2015-07-31 14:05:19 UTC
Created attachment 12320 [details]

All reported issues have been resolved on iOS but on Android pulling to refresh does not populate the list like it does on iOS.
Comment 2 Jason Smith [MSFT] 2016-04-11 07:00:59 UTC
I tried to reproduce the issue however am unable to with the latest version of Xamarin.Forms. I did have to recreate the repro so maybe I did something wrong as I couldn't get the original to work.