Bug 31617 - Can't build classic projects using mdtool
Summary: Can't build classic projects using mdtool
Status: RESOLVED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: iOS add-in ()
Version: 5.9
Hardware: PC Mac OS
: Normal normal
Target Milestone: 5.10 (C6)
Assignee: Jeffrey Stedfast
URL:
Depends on:
Blocks:
 
Reported: 2015-07-03 06:13 UTC by Rolf Bjarne Kvinge [MSFT]
Modified: 2015-07-31 06:48 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
test project (5.72 KB, application/zip)
2015-07-03 06:14 UTC, Rolf Bjarne Kvinge [MSFT]
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Rolf Bjarne Kvinge [MSFT] 2015-07-03 06:13:44 UTC
Repro:
* Create new iOS Classic project.
* Build from command line using "mdtool build"

FATAL ERROR [2015-07-03 12:11:32Z]: System.NullReferenceException: Object reference not set to an instance of an object
  at MonoDevelop.IPhone.IPhoneProject.OnRunTarget (IProgressMonitor monitor, System.String target, MonoDevelop.Projects.ConfigurationSelector configuration, MonoDevelop.Projects.TargetEvaluationContext context) [0x00000] in <filename unknown>:0 
  at MonoDevelop.Projects.Project.OnRunTarget (IProgressMonitor monitor, System.String target, MonoDevelop.Projects.ConfigurationSelector configuration) [0x00094] in /Users/builder/data/lanes/432/4d5d03fa/source/monodevelop/main/src/core/MonoDevelop.Core/MonoDevelop.Projects/Project.cs:105 

Full log: https://gist.github.com/rolfbjarne/8b30a288bb9a9475be0d

This is using XS master:

Xamarin Studio
Version 5.10 (build 309)
Installation UUID: 5d58dc83-4266-49dd-9bd6-88fca7956436
Runtime:
	Mono 4.0.1 ((detached/5a0b19f)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 400010024

Xamarin.Profiler
Not Installed

Apple Developer Tools
Xcode 7.0 (8123.33)
Build 7A121l

Xamarin.iOS
Version: 8.99.0.387 (Business Edition)
Hash: 88b939b
Branch: xcode7
Build date: 2015-07-03 07:21:38+0200

Xamarin.Android
Version: 4.20.0.28
Android SDK: Not found

Xamarin Android Player
Not Installed

Xamarin.Mac
Version: 2.99.0.387 (Business Edition)

Build Information
Release ID: 510000309
Git revision: 21cd3d0d56c3c402a2d4bbbe129a53b373ced492
Build date: 2015-07-02 09:17:52+02
Xamarin addins: 36e72a014c1a219753359958d4f61b0f13a678a7

Operating System
Mac OS X 10.10.4
Darwin Rolfs-Mac-Pro.local 14.4.0 Darwin Kernel Version 14.4.0
    Thu May 28 11:35:04 PDT 2015
    root:xnu-2782.30.5~1/RELEASE_X86_64 x86_64

The same happens with XI master and XI 8.10.
Comment 1 Rolf Bjarne Kvinge [MSFT] 2015-07-03 06:14:48 UTC
Created attachment 11841 [details]
test project
Comment 2 Lluis Sanchez 2015-07-03 11:09:13 UTC
This is a dupe, already fixed.
Comment 3 Rolf Bjarne Kvinge [MSFT] 2015-07-17 10:10:51 UTC
Where is this fixed? It still happens with XS/master from yesterday:

Xamarin Studio
Version 5.10 (build 405)
Installation UUID: 5d58dc83-4266-49dd-9bd6-88fca7956436
Runtime:
	Mono 4.0.2 ((detached/c99aa0c)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 400020005
Comment 4 Lluis Sanchez 2015-07-24 09:52:52 UTC
I can't reproduce. Can you attach all the output you get when running the command?
Comment 5 Rolf Bjarne Kvinge [MSFT] 2015-07-30 08:56:16 UTC
https://gist.github.com/rolfbjarne/e0413353785131630e8e
Comment 6 Rolf Bjarne Kvinge [MSFT] 2015-07-30 08:59:16 UTC
It also happens with a master build from today: https://gist.github.com/rolfbjarne/f8cf3f78edacfdc3fd7f

I've found that only seems to happen with a clean project, if you rebuild it'll succeed the second time.

Xamarin Studio
Version 5.10 (build 477)
Installation UUID: 5d58dc83-4266-49dd-9bd6-88fca7956436
Runtime:
	Mono 4.0.2 ((detached/c99aa0c)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 400020005

Xamarin.Profiler
Not Installed

Apple Developer Tools
Xcode 7.0 (8178.7)
Build 7A165t

Xamarin.iOS
Version: 8.99.3.74 (Business Edition)
Hash: 4631882
Branch: xcode7
Build date: 2015-07-29 10:59:09+0200

Xamarin.Android
Version: 4.20.0.28
Android SDK: Not found

Xamarin Android Player
Not Installed

Xamarin.Mac
Version: 2.99.0.767 (Starter Edition)

Build Information
Release ID: 510000477
Git revision: 453fb307956178b392f1684ea37ce0ad8dc31e1d
Build date: 2015-07-29 18:39:21-04
Xamarin addins: 387fd60cdfcfb4e946e1fe5c6d19af8b2b088eed
Build lane: monodevelop-lion-master

Operating System
Mac OS X 10.10.4
Darwin Rolfs-Mac-Pro.local 14.4.0 Darwin Kernel Version 14.4.0
    Thu May 28 11:35:04 PDT 2015
    root:xnu-2782.30.5~1/RELEASE_X86_64 x86_64
Comment 7 Lluis Sanchez 2015-07-31 06:46:43 UTC
The project builds fine. That's just an exception when shutting down XS.
Comment 8 xamarin-release-manager 2015-07-31 06:48:35 UTC
Fixed in version 5.10.0.497 (master)

Author: Lluis Sanchez
Commit: 7e894848ed2243567c3c26e5a2b5e7b413e9a98b (mono/monodevelop)