Bug 31610 - Entry with IsPassword doesn't fire GotFocus on the passwordbox control (custom renderer)
Summary: Entry with IsPassword doesn't fire GotFocus on the passwordbox control (custo...
Alias: None
Product: Forms
Classification: Xamarin
Component: Forms ()
Version: 1.4.3
Hardware: PC Windows
: Normal normal
Target Milestone: ---
Assignee: Bugzilla
Depends on:
Reported: 2015-07-03 02:47 UTC by Christiaan Veeningen
Modified: 2015-07-21 13:50 UTC (History)
4 users (show)

Is this bug a regression?: ---
Last known good build:

Test project (1.69 MB, application/x-zip-compressed)
2015-07-07 02:29 UTC, Christiaan Veeningen

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description Christiaan Veeningen 2015-07-03 02:47:15 UTC
When I create a custom renderer for an Entry and I set the IsPassword to true, and in the custom renderer i try to assign the GotFocus event on the passwordbox, the event is not fired.

Actually the GotFocus of the Textbox is fired because that one is on top of the password box. I fixed it by setting the IsHitTestVisible property of the textbox control to:

textbox.IsHitTestVisible = textbox.Opacity == 1;
Comment 1 Parmendra Kumar 2015-07-03 09:33:47 UTC

I have tried to reproduce this issue but not able to reproduce this issue.
Could you please provide us a sample project so that I can reproduce this issue at my end.

Comment 2 Christiaan Veeningen 2015-07-07 02:29:55 UTC
Created attachment 11895 [details]
Test project

Added test project
Comment 3 Parmendra Kumar 2015-07-07 07:58:03 UTC
Thanks @Christiaan,

I have checked this issue with attached sample in comment 2, I am getting same behavior as mentioned in bug description.

Screencast: http://www.screencast.com/t/vD0d584oTIo4

IDE Log: https://gist.github.com/Parmendrak/efda5c209db98ed507f2

Environment info:

Microsoft Visual Studio Professional 2013
Version 12.0.30723.00 Update 3
Microsoft .NET Framework
Version 4.5.51641

Installed Version: Professional

Xamarin   3.11.666.0 (ebae43a)
Visual Studio extension to enable development for Xamarin.iOS and Xamarin.Android.

Xamarin.Android (5f55a9ef61c11b6ce0890bc91e4c71b1b92be214)
Visual Studio plugin to enable development for Xamarin.Android.

Xamarin.Forms Intellisense   1.0
Provides intellisense for Xamarin.Forms in the XML editor.

Xamarin.iOS (67b390d0d1bd741582cf7b7fd3ffea08583a3f83)
Visual Studio extension to enable development for Xamarin.iOS.

Xamarin.iOS Unified Migration   1.0
Automated migration for Xamarin iOS Classic projects to Unified

Xamarin.TestCloud.Integration   1.0
Early preview of Xamarin Test Cloud integration
Comment 4 Jason Smith [MSFT] 2015-07-16 17:37:01 UTC
Should be fixed in 1.4.4-pre2