Bug 31597 - Latest Xamarin updates breaks debugging for Xamarin.Android
Summary: Latest Xamarin updates breaks debugging for Xamarin.Android
Alias: None
Product: Android
Classification: Xamarin
Component: Debugger ()
Version: 4.4.x
Hardware: Macintosh Mac OS
: High normal
Target Milestone: 5.1.5 (C5SR3)
Assignee: Bugzilla
Depends on: 31575
  Show dependency tree
Reported: 2015-07-02 16:58 UTC by ulrike_axen
Modified: 2015-08-10 14:52 UTC (History)
9 users (show)

Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description ulrike_axen 2015-07-02 16:58:24 UTC
The debugger no longer stops at breakpoints, or when it does, the breakpoint does not correspond to the stacktrace.
Comment 1 ulrike_axen 2015-07-02 16:59:30 UTC
I already did a complete clean/rebuild. Restart. The issue has been duplicated by another developer here.
Comment 2 Saurabh 2015-07-03 02:08:10 UTC
@Ulrike, I tried it with latest stable builds and I am unable to reproduce this Issue. Could you please let me know which builds you are using?
Comment 3 Saurabh 2015-07-03 02:08:50 UTC
An update to comment#2

My builds are:

=== Xamarin Studio ===

Version 5.9.4 (build 5)
Installation UUID: 2939b8b4-8977-42bd-82d6-100275ccd9cd
	Mono 4.0.2 ((detached/c99aa0c)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 400020005

=== Apple Developer Tools ===

Xcode 6.2 (6776)
Build 6C131e

=== Xamarin.Mac ===

Version: (Enterprise Edition)

=== Xamarin.iOS ===

Version: (Enterprise Edition)
Hash: ef8c2f7
Branch: master
Build date: 2015-06-22 21:28:32-0400

=== Xamarin.Android ===

Version: (Enterprise Edition)
Android SDK: /Users/360_macmini/Library/Developer/Xamarin/android-sdk-mac_x86
	Supported Android versions:
		2.3    (API level 10)
		4.0.3  (API level 15)
		4.1    (API level 16)
		4.2    (API level 17)
		4.3    (API level 18)
		4.4    (API level 19)
		4.4.87 (API level 20)
		5.0    (API level 21)
Java SDK: /usr
java version "1.7.0_75"
Java(TM) SE Runtime Environment (build 1.7.0_75-b13)
Java HotSpot(TM) 64-Bit Server VM (build 24.75-b04, mixed mode)

=== Xamarin Android Player ===

Version: Unknown version
Location: /Applications/Xamarin Android Player.app

=== Build Information ===

Release ID: 509040005
Git revision: 8010a90f6e246b32364e3fb46ef2c9d1be9c9a2b
Build date: 2015-06-08 16:52:06-04
Xamarin addins: 7e93e9c3503f28770f23ce1b7eafd829919f18e8

=== Operating System ===

Mac OS X 10.9.4
Darwin 360-MACMINIs-Mac-mini-2.local 13.3.0 Darwin Kernel Version 13.3.0
    Tue Jun  3 21:27:35 PDT 2014
    root:xnu-2422.110.17~1/RELEASE_X86_64 x86_64
Comment 4 Peter Collins 2015-07-06 15:08:29 UTC
This appears like it could be related or a duplicate of an issue we're currently investigating.

@Ulrike would you be able to attach a project, or provide the specific steps in which you're able to reproduce this issue?
Comment 5 ulrike_axen 2015-07-06 15:47:09 UTC
There are no specific steps. It was reproduced by two developers working in different areas of our app with the latest updates to Xamarin. Unfortunately for this, our app is huge and complex (and proprietary). If you find a fix for the issue, I would be happy to test it. Also, if you absolutely need our project to reproduce this, then we would have to have a private place to send you the very large project, and I would need to check internally if that is OK.
Comment 6 Peter Collins 2015-07-06 15:56:01 UTC
That all sounds perfectly reasonable. I'll report back here once we have some builds that should address the issue.
Comment 7 T.J. Purtell 2015-07-07 18:47:58 UTC
This is punishing some devs on my team too :(  The stack trace looks correct in terms of method names, but the File name and line numbers are completely wrong.  Same happens when printing stack trace via Console.Log("{0}", e.ToString())
Comment 8 T.J. Purtell 2015-07-07 19:39:09 UTC
Downgrading to the previous release of Xamarin.Android access from the Xamarin Dashboard page resolved this for us temporarily.
Comment 12 Mohit Kheterpal 2015-07-31 13:36:02 UTC
as per comment 11, closing this issue by marking it as Verified.
Comment 13 ulrike_axen 2015-08-04 10:10:14 UTC
Because I was out of the office, I was not able to test this until today. On the Mac, seems to fix the issue with debugging our project. Thank you for the fix. Will it be in the next Stable version?
Comment 14 PJ 2015-08-04 10:21:27 UTC
Hi Ulrike, yes indeed, and thanks for letting us know it worked for you.

The fix is currently out in the Beta channel, and will be part of a Stable release next week.