Bug 31558 - [XVS 3.11] "Erreur 7 error MT0000" when building and running on device (but not simulator)
Summary: [XVS 3.11] "Erreur 7 error MT0000" when building and running on device (but n...
Status: RESOLVED DUPLICATE of bug 31540
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: iOS ()
Version: 3.11 (C5)
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Bugzilla
Depends on:
Reported: 2015-07-01 18:51 UTC by Brendan Zagaeski (Xamarin Team, assistant)
Modified: 2015-07-02 12:56 UTC (History)
4 users (show)

Is this bug a regression?: ---
Last known good build:

Detailed version info (6.99 KB, text/plain)
2015-07-01 18:51 UTC, Brendan Zagaeski (Xamarin Team, assistant)
VS2013 Logs (6.50 KB, application/x-zip-compressed)
2015-07-02 05:20 UTC, Axel
Mac Build Logs (1.98 KB, application/zip)
2015-07-02 05:28 UTC, Axel

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description Brendan Zagaeski (Xamarin Team, assistant) 2015-07-01 18:51:16 UTC
Created attachment 11812 [details]
Detailed version info

I am copying the available information so far into a bug report for tracking.

From: http://forums.xamarin.com/discussion/comment/136517/#Comment_136517:

> With this new release I am unable to debug on iOS Device from VS2013.....
> When I start the debugger that app is copied to the Device (iPhone 6, iOS 8.3)
> and I get :

> Erreur 7 error MT0000: Unexpected error - Please file a bug report at
> http://bugzilla.xamarin.com Xamarin.iOS Extension 0 0

> The app dont even start.
> It works fine on the simulator.

> This is very very annyoing because my app use bunch of core motion senors than
> I can't simulate.
> I was using 3.9.547 just before and it worked fine.

## Reported regression status: regression between 3.9.547 and 3.11.666 (Cycle 5 SR 2)

## Version information (brief)

### Windows

Microsoft Visual Studio Ultimate 2013
Version 12.0.31101.00 Update 4
Microsoft .NET Framework
Version 4.5.51641

Xamarin   3.11.666.0 (ebae43a)
Xamarin.Android (5f55a9ef61c11b6ce0890bc91e4c71b1b92be214)
Xamarin.Forms Intellisense   1.0
Xamarin.iOS (67b390d0d1bd741582cf7b7fd3ffea08583a3f83)

### Mac build host 

Xamarin.iOS (ef8c2f7)
Mono 4.0.2 (detached/c99aa0c)

Xcode 6.4 (7720), Build 6E35b

Mac OS X 10.10.3
Comment 1 Brendan Zagaeski (Xamarin Team, assistant) 2015-07-01 19:02:25 UTC
The customer noted that they were able to reproduce the problem using a "new from template" Xamarin.Forms app.

Standard bug information that is currently _missing_: all of the log files.

The "error MT0000" error is usually accompanied by additional, more descriptive error messages in the log files.

In this case, all of the following log files would be good to gather and add to the bug report:

- The diagnostic msbuild output.

- The XamarinVS logs from: %LOCALAPPDATA%\Xamarin\Log. Ideally, you can delete this folder, reproduce the problem, and then zip up and attach back the whole folder to provide a "clean" set of logs.

- All of the Mac build host logs from ~/Library/Logs/Xamarin/MonoTouchVS. The easiest option is to zip up and attach the whole folder. Again a "clean" set of logs is ideal.

- The contents of the console log from the physical iOS device after the failure occurs. (See "iOS device logs" on https://kb.xamarin.com/customer/portal/articles/1675684#ios-device-logs.)

See https://kb.xamarin.com/customer/portal/articles/1675684-where-can-i-find-my-version-information-and-logs- for additional reference on where to locate these various logs.
Comment 2 Axel 2015-07-02 05:20:37 UTC
Created attachment 11817 [details]
VS2013 Logs
Comment 3 Axel 2015-07-02 05:28:19 UTC
Created attachment 11818 [details]
Mac Build Logs
Comment 4 Axel 2015-07-02 05:29:47 UTC
FYI, it also fail with a new Forms project and updating nugets to the latest stable forms release 1,4,3
Comment 5 Brendan Zagaeski (Xamarin Team, assistant) 2015-07-02 11:22:39 UTC
Thanks for the logs. Based on the logs, this looks like a duplicate of Bug 31540.

If you have updated to Xcode 6.4 on the Mac build host or iOS 8.4 on the device, then you will need to install the compatibility update Xamarin.iOS 8.10.3 (released yesterday) on the Mac build host .

Let us know if updating to Xamarin.iOS 8.10.3 on the Mac build host does not resolve the issue.

Comment 6 Axel 2015-07-02 12:51:13 UTC
Your updatee has solved the problem.

Thx a lot
Comment 7 Brendan Zagaeski (Xamarin Team, assistant) 2015-07-02 12:56:22 UTC
Excellent. Glad to hear the update got you back up and running!

*** This bug has been marked as a duplicate of bug 31540 ***