Bug 31540 - Cannot deploy to iPad2 device after updating Xamarin
Summary: Cannot deploy to iPad2 device after updating Xamarin
Alias: None
Product: iOS
Classification: Xamarin
Component: Xamarin.iOS.dll ()
Version: XI 8.10
Hardware: PC Windows
: --- normal
Target Milestone: Untriaged
Assignee: Bugzilla
: 31558 ()
Depends on:
Reported: 2015-07-01 11:42 UTC by Michael Rumpler
Modified: 2015-07-02 12:56 UTC (History)
3 users (show)

Is this bug a regression?: ---
Last known good build:

Log files from Windows and OSX (74.88 KB, application/x-zip-compressed)
2015-07-01 11:42 UTC, Michael Rumpler

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description Michael Rumpler 2015-07-01 11:42:37 UTC
Created attachment 11804 [details]
Log files from Windows and OSX

Today I updated a bunch of products. Unfortunately now I cannot deploy to my iPad anymore from VS. First I tried my app, but I also tried to deploy https://github.com/xamarin/xamarin-forms-samples/tree/master/WorkingWithListviewNative and that did not work either. I can however deploy to the iPad2 simulator.

I get this error in VS:
error MT0000: Unexpected error - Please file a bug report at http://bugzilla.xamarin.com	
Xamarin.iOS Extension	0	0	

In the devenv*.log file I found a bit more info:

Xamarin.VisualStudio.IOS.Utilities.BuildServer Error: 0 : [2015-07-01 17:10:52.5] OK
Build server returned an Error.
warning MT1003: Could not kill the application 'com.your-company.WorkingWithListViewPerf.iOS'. You may have to kill the application manually.
error MT0000: Unexpected error - Please file a bug report at http://bugzilla.xamarin.com
MonoTouch.MobileDevice.MobileDeviceException: Invalid Disk Image Error (error: 0xe8000033)
  at MonoTouch.Installation.Device.MountDeveloperImage () [0x00000] in <filename unknown>:0 
  at MonoTouch.Installation.Installer.FindApplication (MonoTouch.Installation.Device d, System.String appId) [0x00000] in <filename unknown>:0 
  at MonoTouch.Installation.Installer+<LaunchApplication>c__AnonStorey3.<>m__0 (MonoTouch.Installation.Device d) [0x00000] in <filename unknown>:0 

Please ensure your device is connected...
Connected to: Michaels iPad

I attached the log files which I think are relevant. Tell me if you need more.

Yesterday everything was deploying fine. This morning I updated Xcode and Xamarin on my build server and Xamarin on Windows.

Here is what I have currently installed on Windows:

Microsoft Visual Studio Professional 2013
Version 12.0.31101.00 Update 4
Microsoft .NET Framework
Version 4.6.00057

Xamarin   3.11.666.0 (ebae43a)
Visual Studio extension to enable development for Xamarin.iOS and Xamarin.Android.

Xamarin.Android (5f55a9ef61c11b6ce0890bc91e4c71b1b92be214)
Visual Studio plugin to enable development for Xamarin.Android.

Xamarin.Forms Intellisense   1.0
Provides intellisense for Xamarin.Forms in the XML editor.

Xamarin.iOS (67b390d0d1bd741582cf7b7fd3ffea08583a3f83)
Visual Studio extension to enable development for Xamarin.iOS.

Xamarin.iOS Unified Migration   1.0
Automated migration for Xamarin iOS Classic projects to Unified

Xamarin.TestCloud.Integration   1.0
Early preview of Xamarin Test Cloud integration

And this is what's installed on my build server:

=== Xamarin Studio ===

Version 5.9.4 (build 5)
Installation UUID: c0a9010c-fec9-4b31-ae8e-a72209b33ddb
	Mono 4.0.2 ((detached/c99aa0c)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 400020005

=== Apple Developer Tools ===

Xcode 6.4 (7720)
Build 6E35b

=== Xamarin.iOS ===

Version: (Business Edition)
Hash: ef8c2f7
Branch: master
Build date: 2015-06-22 21:28:32-0400

=== Xamarin.Mac ===

Not Installed

=== Build Information ===

Release ID: 509040005
Git revision: 8010a90f6e246b32364e3fb46ef2c9d1be9c9a2b
Build date: 2015-06-08 16:52:06-04
Xamarin addins: 7e93e9c3503f28770f23ce1b7eafd829919f18e8

=== Operating System ===

Mac OS X 10.10.3
Darwin MacMaster 14.3.0 Darwin Kernel Version 14.3.0
    Mon Mar 23 11:59:05 PDT 2015
    root:xnu-2782.20.48~5/RELEASE_X86_64 x86_64
Comment 1 Rolf Bjarne Kvinge [MSFT] 2015-07-01 11:58:38 UTC
Which iOS version does your iPad have?
Comment 2 Michael Rumpler 2015-07-01 15:09:10 UTC
Comment 3 Brendan Zagaeski (Xamarin Team, assistant) 2015-07-01 16:09:04 UTC
Perhaps we'll be lucky, and the Xamarin.iOS 8.10.3 Xcode 6.4 compatibility update that was just released will help with this (since the Mac build host shows that Xcode 6.4 is installed)?

Comment 4 Brendan Zagaeski (Xamarin Team, assistant) 2015-07-01 16:27:41 UTC
For bookkeeping, I'll note that if updating to Xamarin.iOS 8.10.3 _does_ help, then this might be a duplicate of non-public Bug 29884.

The brief summary of Bug 29884 is that Xcode 6.4 is missing some support files for iOS 8.3 that were present in Xcode 6.3. Xamarin.iOS 8.10.3 skips check that causes the problem, which is apparently also what Xcode 6.4 itself does.
Comment 5 Rolf Bjarne Kvinge [MSFT] 2015-07-02 01:50:56 UTC
@Michael, does upgrading to Xamarin.iOS 8.10.3 fix the problem?
Comment 6 Michael Rumpler 2015-07-02 03:18:25 UTC
Yes, installing Xamarin.iOS on the build server fixed it.

Thanks for the fast response and fix!!
Comment 7 Brendan Zagaeski (Xamarin Team, assistant) 2015-07-02 12:56:22 UTC
*** Bug 31558 has been marked as a duplicate of this bug. ***