Bug 3153 - Addin publishing fails in final step
Summary: Addin publishing fails in final step
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: General ()
Version: 2.8.6
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Lluis Sanchez
Depends on:
Reported: 2012-01-31 09:25 UTC by alex
Modified: 2012-02-01 07:42 UTC (History)
1 user (show)

Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description alex 2012-01-31 09:25:16 UTC

I tried to publish my plugin on the official addins repo, I successfully finished inserting the source directory, and the build log says it processed everything fine -- but after it showed me the "Publish" button on the page, the .mpack files aren't existing in the repo, I can't download them, they aren't listed in the Beta-Channel of MonoDevelop's repository; In the build log there's also written:
Building Package

ERROR: Could not read folder info file<br/>Creating package MonoDevelop.D_0.2.8.1.mpack
in the very last section.

What does this error message mean?

The addin-project.xml contains
<AddinProject appVersion="2.7">
	<Project platforms="Win32 Mac Linux">

Next to the MonoDevelop.D.dll, there also shall be a D_Parser.dll included in the mpack file - could this be the reason why it's not finished publishing the files?

What have I done wrong so far?

Comment 1 alex 2012-01-31 09:46:29 UTC
Additionally I guess it's worth to say that the publishing status is stated as "Pending".. 
I don't know what's required furthermore in order to build&upload MonoDevelop Addins :-/
Comment 2 Mikayla Hutchinson [MSFT] 2012-01-31 11:48:21 UTC
NEEDINFO is for when we need info for from the reporter, not the other way round :)
Comment 3 alex 2012-01-31 12:30:01 UTC
Usability fail :D - but hey, that's the only way my report became noticed.
Comment 4 Mikayla Hutchinson [MSFT] 2012-01-31 12:33:16 UTC
Not really, I read every bug report, even though I can't handle most of them myself. If we just went on the tags and state, the report would have sat in the "waiting for info" pile forever :)
Comment 5 alex 2012-01-31 12:44:50 UTC
ok :)
Comment 6 Lluis Sanchez 2012-02-01 04:19:05 UTC
The add-in has been published.
Comment 7 Lluis Sanchez 2012-02-01 04:20:18 UTC
BTW, do you have an add-in version for MD 2.8.x? I'd love to try it.
Comment 8 alex 2012-02-01 04:49:19 UTC
Thanks for the quick response! So is it possible now that I can push some new sources to git and it'll publish new versions automatically?

I'm using the latest beta version, so 2.8.6 -- When will the addin/core versions be switched to 2.8 then?, because I've seen that the current repo still becomes redirected to 2.7 internally..
Comment 9 Lluis Sanchez 2012-02-01 05:42:55 UTC
Yes, new updates will be automatically published.
About 2.7, you're right, 2.8.6 is backwards compatible with 2.7, so add-ins targeting 2.7 are be available for MD 2.8, I just checked it :).
BTW, nice work!
Comment 10 alex 2012-02-01 06:00:11 UTC
Ok, thanks! :)
Comment 11 Lluis Sanchez 2012-02-01 06:07:00 UTC
I tried installing the add-in on the latest MD and I get an error when I try to create a project. The problem is that the add-in is being built against MD 2.7 and looks like there is a slight breaking change wrt 2.8. Can you please set appVersion="2.8" in your addin-project.xml file? I think this should fix the problem.
Comment 12 alex 2012-02-01 06:39:03 UTC
done; well it's somehow confusing that there is MD already though the internal libraries are still 2.7 -- is the latest downloadable release of MonoDevelop 2.8 internally already? If so, I'll change everything to 2.8 then..
Comment 13 alex 2012-02-01 06:42:01 UTC
Wow, it's saying "Cannot find central directory" after I pushed the latest few changes .. any reasons for this? :D
Comment 14 alex 2012-02-01 07:42:22 UTC
In fact, the update was the reason - I hope you don't mind if I switched it back now. :)