Bug 31419 - MT3001 Could not AOT Assembly - SharpSerializer Component Sample
Summary: MT3001 Could not AOT Assembly - SharpSerializer Component Sample
Alias: None
Product: iOS
Classification: Xamarin
Component: Mono runtime / AOT compiler ()
Version: XI 8.10
Hardware: PC Mac OS
: --- normal
Target Milestone: Untriaged
Assignee: Zoltan Varga
Depends on:
Reported: 2015-06-26 15:01 UTC by Jon Dick
Modified: 2015-08-04 05:49 UTC (History)
3 users (show)

Is this bug a regression?: ---
Last known good build:

log (149.90 KB, text/plain)
2015-06-26 15:01 UTC, Jon Dick

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description Jon Dick 2015-06-26 15:01:26 UTC
Created attachment 11758 [details]

Looks like on Xamarin.iOS 8.9.3 and higher the Unified API sample in the Sharp Serializer component will not compile due to a MT3001 Could not AOT assembly error.  This apparently worked in 8.9.1.  I'm seeing the same error in 8.9.10.

I've attached a full log with -v -v -v -v

Steps to reproduce:

1. Download and unzip the SharpSerializer Component https://components.xamarin.com/view/SharpSerializer
2. Open the samples/SharpSerializer.iOS/SharpSerializer.iOS.sln
3. Attempt to compile for device (so that AOT is enabled)
Comment 1 Zoltan Varga 2015-06-26 15:21:26 UTC
Probably a dup of:
Comment 2 Jon Dick 2015-06-26 15:48:44 UTC
This is fixed in which is currently on the beta channel
Comment 3 Danish Akhtar 2015-08-04 05:49:36 UTC
Today, I have checked this issue with X.iOS after following the steps mentioned in bug description. Now this is working fine, we are successfully able to run SharpSerializer.iOS sample on device.

Hence closing this issue.