Bug 31328 - Can't add a new project to my solution in Xamarin Studio 5.9 on Mac OSX
Summary: Can't add a new project to my solution in Xamarin Studio 5.9 on Mac OSX
Status: RESOLVED ANSWERED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: General ()
Version: 5.9
Hardware: Macintosh Mac OS
: Normal normal
Target Milestone: master
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2015-06-23 12:52 UTC by ahmed
Modified: 2015-07-30 10:56 UTC (History)
4 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Screen cap of XS with error message 1 when creating new project - (1.09 MB, application/pdf)
2015-06-23 12:52 UTC, ahmed
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED ANSWERED

Description ahmed 2015-06-23 12:52:50 UTC
Created attachment 11720 [details]
Screen cap of XS with error message 1 when creating new project -

I'm an activated enterprise user but whenever I try to create a new solution or project in XS on mac - I get this UnAuthorized Access error -this happens when creating a solution or adding a project - (I tried creating the project in various locations on my mac) I made sure the path had full access (Everyone -read/write) and I still get this error: 
 
PROJECT ERROR:
=================

System.UnauthorizedAccessException: Access to the path "iWellWatchWatchKitApp" is denied.
  at System.IO.Directory.CreateDirectoriesInternal (System.String path) [0x0006c] in /private/tmp/source-mono-mac-4.0.0-branch/bockbuild-mono-4.0.0-branch/profiles/mono-mac-xamarin/build-root/mono-4.0.1/mcs/class/corlib/System.IO/Directory.cs:114 
  at System.IO.Directory.CreateDirectory (System.String path) [0x000a4] in /private/tmp/source-mono-mac-4.0.0-branch/bockbuild-mono-4.0.0-branch/profiles/mono-mac-xamarin/build-root/mono-4.0.1/mcs/class/corlib/System.IO/Directory.cs:78 
  at MonoDevelop.Ide.Templates.ProjectDescriptor.CreateProjectCI (MonoDevelop.Projects.ProjectCreateInformation projectCI) [0x000c0] in /Users/builder/data/lanes/1858/5a524e17/source/monodevelop/main/src/core/MonoDevelop.Ide/MonoDevelop.Ide.Templates/ProjectDescriptor.cs:245 
  at MonoDevelop.Ide.Templates.ProjectTemplate.GetItemSpecificCreateInfo (ISolutionItemDescriptor descriptor, MonoDevelop.Projects.ProjectCreateInformation cInfo) [0x00010] in /Users/builder/data/lanes/1858/5a524e17/source/monodevelop/main/src/core/MonoDevelop.Ide/MonoDevelop.Ide.Templates/ProjectTemplate.cs:394 
  at MonoDevelop.Ide.Templates.ProjectTemplate.CreateProjects (MonoDevelop.Projects.SolutionItem policyParent, MonoDevelop.Projects.ProjectCreateInformation cInfo) [0x00051] in /Users/builder/data/lanes/1858/5a524e17/source/monodevelop/main/src/core/MonoDevelop.Ide/MonoDevelop.Ide.Templates/ProjectTemplate.cs:352 
  at MonoDevelop.Ide.Templates.ProjectTemplatingProvider.ProcessTemplate (MonoDevelop.Ide.Templates.DefaultSolutionTemplate template, MonoDevelop.Ide.Projects.NewProjectConfiguration config, MonoDevelop.Projects.SolutionFolder parentFolder) [0x00042] in /Users/builder/data/lanes/1858/5a524e17/source/monodevelop/main/src/core/MonoDevelop.Ide/MonoDevelop.Ide.Templates/ProjectTemplatingProvider.cs:71 
  at MonoDevelop.Ide.Templates.ProjectTemplatingProvider.ProcessTemplate (MonoDevelop.Ide.Templates.SolutionTemplate template, MonoDevelop.Ide.Projects.NewProjectConfiguration config, MonoDevelop.Projects.SolutionFolder parentFolder) [0x0000a] in /Users/builder/data/lanes/1858/5a524e17/source/monodevelop/main/src/core/MonoDevelop.Ide/MonoDevelop.Ide.Templates/ProjectTemplatingProvider.cs:57 
  at MonoDevelop.Ide.Templates.TemplatingService.ProcessTemplate (MonoDevelop.Ide.Templates.SolutionTemplate template, MonoDevelop.Ide.Projects.NewProjectConfiguration config, MonoDevelop.Projects.SolutionFolder parentFolder) [0x00014] in /Users/builder/data/lanes/1858/5a524e17/source/monodevelop/main/src/core/MonoDevelop.Ide/MonoDevelop.Ide.Templates/TemplatingService.cs:112 
  at MonoDevelop.Ide.Projects.NewProjectDialogController.CreateProject () [0x00149] in /Users/builder/data/lanes/1858/5a524e17/source/monodevelop/main/src/core/MonoDevelop.Ide/MonoDevelop.Ide.Projects/NewProjectController.cs:580 

Background
============

I'm behind a corporate web proxy which is set as "Auto Proxy Discovery" - but I have no problems getting access to Web Content from Xamarin Studion(E.g. account activation, updates and access to blog content inside of Xamarin Studio - yet I get this error when I try and add projects or add/update nuget packages on new projects/solutions (see LOG ERRORS BELOW AFTER MY INFO SECTION)!!!

MY INFO:
=============

=== Xamarin Studio ===

Version 5.9.3 (build 1)
Installation UUID: 589566f0-cbfa-4c95-9935-a084724b35dd
Runtime:
	Mono 4.0.1 ((detached/ed1d3ec)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 400010044

=== Apple Developer Tools ===

Xcode 6.3.2 (7718)
Build 6D2105

=== Xamarin.Mac ===

Not Installed

=== Xamarin.iOS ===

Version: 8.10.1.64 (Enterprise Edition)
Hash: e6ebd18
Branch: master
Build date: 2015-05-21 21:55:09-0400

=== Xamarin.Android ===

Version: 5.1.3.1 (Enterprise Edition)
Android SDK: /Users/ahmedkhan/Library/Developer/Xamarin/android-sdk-mac_x86
	Supported Android versions:
		2.3   (API level 10)
		4.0.3 (API level 15)
		4.2   (API level 17)
		4.3   (API level 18)
		4.4   (API level 19)
Java SDK: /usr
java version "1.6.0_65"
Java(TM) SE Runtime Environment (build 1.6.0_65-b14-466.1-11M4716)
Java HotSpot(TM) 64-Bit Server VM (build 20.65-b04-466.1, mixed mode)

=== Xamarin Android Player ===

Version: Unknown version
Location: /Applications/Xamarin Android Player.app

=== Build Information ===

Release ID: 509030001
Git revision: 5a524e1726ed103fdd4fe37e0356f2b35466ce9d
Build date: 2015-06-02 16:35:08-04
Xamarin addins: 51957cfbd06be911b212671ad05c2c6221ac90f9

=== Operating System ===

Mac OS X 10.10.3
Darwin Ahmeds-MacBook-Pro.local 14.3.0 Darwin Kernel Version 14.3.0
    Mon Mar 23 11:59:05 PDT 2015
    root:xnu-2782.20.48~5/RELEASE_X86_64 x86_64

================================================================================================

IDE LOG ERRORS

SEE ATTACHED PDF
Comment 1 Matt Ward 2015-06-24 08:06:24 UTC
The project error in the log does not match the error being displayed in the error dialog, which is interesting. The error in the dialog seems to be happening all the time in the IDE log file.

Can you try disabling the TFS addin and see if you can create a new solution?

If that does not work, shutdown Xamarin Studio, restart it and just try to create a new solution. Then can you attach the latest IDE log to the bug report after you have reproduced the problem?
Comment 2 ahmed 2015-06-25 15:31:11 UTC
I tried Disabling the TFS add in and that worked - I'm no longer getting the "Unauthorized Access" error and I can create and add projects 

thanks
Ahmed
Comment 3 Lluis Sanchez 2015-07-30 10:56:25 UTC
Closing.