Bug 31214 - CustomControl failes on Android but not on iOS.
Summary: CustomControl failes on Android but not on iOS.
Alias: None
Product: Forms
Classification: Xamarin
Component: Android ()
Version: 1.4.2
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Bugzilla
Depends on:
Reported: 2015-06-18 03:46 UTC by R.Schindler
Modified: 2016-08-09 13:52 UTC (History)
3 users (show)

Tags: ngf
Is this bug a regression?: ---
Last known good build:

Test Project Part 1 (7.53 MB, application/octet-stream)
2015-06-18 04:17 UTC, R.Schindler
Test Project Part 2 (3.49 MB, application/octet-stream)
2015-06-18 04:18 UTC, R.Schindler
Test Project 2 Part 1 (7.53 MB, application/octet-stream)
2015-06-18 10:53 UTC, R.Schindler
Test Project 2 Part 2 (3.48 MB, application/octet-stream)
2015-06-18 10:54 UTC, R.Schindler

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description R.Schindler 2015-06-18 03:46:56 UTC
I tried to create a Custom Slider with a StepperValue.
I used the one provided with XLabs and it didn't worked and then I recreated the class in my project and it failed also.

I'm not sure what the problem exactly is, but it only happens on Android devices. I tested this on an Galaxy Note 2 (Android 5.0) and a Gigaset Quanta Tablet (Android 4.2.2).

If you run the provided test project on an Android device and move the slider you will see that it stops working and GC gets in a loop.

If you comment the first declaration of the slider and uncomment the second one you can see that it is working then. Which is really weird because all I'm doing is to convert the values to float. As I need the double values to get the correct output from the slider I need to get this to work.

I think this is a problem with the Forms implementation for Android.

I hope you can find the issue :)

Password for the .zip file is xftest
Comment 1 R.Schindler 2015-06-18 04:17:14 UTC
Created attachment 11660 [details]
Test Project Part 1
Comment 2 R.Schindler 2015-06-18 04:18:12 UTC
Created attachment 11661 [details]
Test Project Part 2
Comment 3 R.Schindler 2015-06-18 10:53:26 UTC
Created attachment 11664 [details]
Test Project 2 Part 1
Comment 4 R.Schindler 2015-06-18 10:54:20 UTC
Created attachment 11665 [details]
Test Project 2 Part 2
Comment 5 R.Schindler 2015-06-18 10:55:16 UTC
Please use Test Project 2 as the first one can be made obsolote. And now I don't use a custom control anymore.
Comment 6 Jason Smith [MSFT] 2015-06-19 13:59:14 UTC
You seem to be causing a feedback loop, its worth noting this method of coercion will probably have side effects you dont want (2 way binding will fail).
Comment 7 Rui Marinho 2016-08-09 13:52:46 UTC
Thank you for your bug report. 

As we have not received more feedback we cannot properly triage your bug and are marking it resolved. 

Warm regards, 
Xamarin Forms Team