Bug 31109 - Problems with Assertions of the runtime in two cases
Summary: Problems with Assertions of the runtime in two cases
Alias: None
Product: Runtime
Classification: Mono
Component: General ()
Version: 4.0.0
Hardware: PC Linux
: --- normal
Target Milestone: ---
Assignee: Bugzilla
Depends on:
Reported: 2015-06-15 11:42 UTC by Ralph
Modified: 2017-08-11 08:49 UTC (History)
6 users (show)

Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on GitHub or Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description Ralph 2015-06-15 11:42:13 UTC
With happens in each case. --> Therefor I tried Continuous Integration build mono/20150611214718
In CI it happens with environment created by mono-snapshot but not by monodevelop (if monodevelop is attached or not makes no difference as long it is started from inside monodevelop it works with CI)
* Assertion at sgen-alloc.c:460, condition `*p == NULL' not met


  at <unknown> <0xffffffff>
  at Castle.Proxies.ServiceBaseProxy.GetRepository<TO, TR> () <0x00177>


Happens in each case with CI build but not with
* Assertion at method-to-ir.c:13533, condition `ins->opcode >= MONO_CEE_LAST' not met


  at <unknown> <0xffffffff>
  at Cloo.ComputeCommandQueue.Write<int> (Cloo.ComputeBufferBase`1<int>,bool,long,long,intptr,System.Collections.Generic.ICollection`1<Cloo.ComputeEventBase>) <IL 0x00061, 0x002f7>
  at Cloo.ComputeCommandQueue.WriteToBuffer<int> (int[],Cloo.ComputeBufferBase`1<int>,bool,long,long,long,System.Collections.Generic.IList`1<Cloo.ComputeEventBase>) <IL 0x00028, 0x00167>
  at Cloo.ComputeCommandQueue.WriteToBuffer<int> (int[],Cloo.ComputeBufferBase`1<int>,bool,System.Collections.Generic.IList`1<Cloo.ComputeEventBase>) <IL 0x00011, 0x000c3>
Comment 1 ben.mcmill 2017-03-21 09:04:14 UTC
is there any solution to this?
I get the same problem
Comment 2 ben.mcmill 2017-03-22 00:48:22 UTC
I was using mono version 4.2.1 (which I think is the Xamarin default?)
Upgrading to mono version 4.8.0 solved this problem for me.
Comment 3 Rodrigo Kumpera 2017-08-11 08:49:26 UTC
closing per last comment.