Bug 30917 - No intellisense for subsequent method parameters after first
Summary: No intellisense for subsequent method parameters after first
Status: RESOLVED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Text Editor ()
Version: 5.9
Hardware: Macintosh Mac OS
: Normal normal
Target Milestone: master
Assignee: Mike Krüger
URL:
Depends on:
Blocks:
 
Reported: 2015-06-08 14:30 UTC by Neal
Modified: 2015-06-16 03:01 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
demo app (11.91 KB, application/zip)
2015-06-08 14:30 UTC, Neal
Details
screencast (4.29 MB, application/zip)
2015-06-08 14:31 UTC, Neal
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Neal 2015-06-08 14:30:40 UTC
Created attachment 11521 [details]
demo app

Hello,

I attached a sample and video to show this issue that would be great if you could improve for us.  The example is simple, I have two enums.  I create a method that has multiple params each are enums.  When I write code to call that method I'm given good intellisense to pick the enum for the first param but nothing for further params.  This occurs quite a bit in code such as when OR'ing together AutoResizing masks in iOS.

Thank you.
Comment 1 Neal 2015-06-08 14:31:00 UTC
Created attachment 11522 [details]
screencast
Comment 2 Akhilesh kumar 2015-06-09 08:53:53 UTC
I am also able to reproduce this issue. When start writing to call the method having enum parameter, the intellisense window appears for first enum parameter and it is selected by default in intellisense window but for second enum parameter it does not display intellisense window until we do not start writing.

Screencast: http://screencast.com/t/Y3X5WBIuk1

Environment info:

=== Xamarin Studio ===

Version 5.9.4 (build 4)
Installation UUID: 91997f85-0008-4b4c-9f53-c7f991fcdae3
Runtime:
	Mono 4.0.2 ((detached/198235d)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 400020004

=== Apple Developer Tools ===

Xcode 6.3.2 (7718)
Build 6D2105

=== Xamarin.Mac ===

Version: 2.1.0.1083 (Enterprise Edition)

=== Xamarin.iOS ===

Version: 8.10.2.16 (Enterprise Edition)
Hash: b2ebbc0
Branch: master
Build date: 2015-06-06 01:13:21-0400

=== Xamarin.Android ===

Version: 5.1.4.8 (Enterprise Edition)
Android SDK: /Users/360_macmini/Desktop/android-sdk-macosx
	Supported Android versions:
		2.3    (API level 10)
		4.0.3  (API level 15)
		4.1    (API level 16)
		4.2    (API level 17)
		4.3    (API level 18)
		4.4    (API level 19)
		4.4.87 (API level 20)
		5.0    (API level 21)
Java SDK: /usr
java version "1.7.0_65"
Java(TM) SE Runtime Environment (build 1.7.0_65-b17)
Java HotSpot(TM) 64-Bit Server VM (build 24.65-b04, mixed mode)

=== Xamarin Android Player ===

Version: Unknown version
Location: /Applications/Xamarin Android Player.app

=== Build Information ===

Release ID: 509040004
Git revision: 0c8e73f6b66e066a642724a8241a0998b6329180
Build date: 2015-06-08 11:30:54-04
Xamarin addins: 7e93e9c3503f28770f23ce1b7eafd829919f18e8

=== Operating System ===

Mac OS X 10.10.2
Darwin Apples-iMac.local 14.1.0 Darwin Kernel Version 14.1.0
    Mon Dec 22 23:10:38 PST 2014
    root:xnu-2782.10.72~2/RELEASE_X86_64 x86_64
Comment 3 Mike Krüger 2015-06-16 03:01:07 UTC
Fixed in 6.0