Bug 309 - project's root files are not being bundled on the final app
Summary: project's root files are not being bundled on the final app
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: iOS add-in ()
Version: 2.6 RC 1
Hardware: PC Mac OS
: --- blocker
Target Milestone: ---
Assignee: Lluis Sanchez
: 200 ()
Depends on:
Reported: 2011-08-16 20:07 UTC by Alex Soto
Modified: 2011-08-24 10:28 UTC (History)
10 users (show)

Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description Alex Soto 2011-08-16 20:07:17 UTC
Any files marked as content on root project's folder aren't being bundled into the final app, I'm using monotouch, mono 2.10.4 and MonoDevelop 2.6RC1
Comment 1 Mikayla Hutchinson [MSFT] 2011-08-17 16:46:09 UTC
This was fixed a couple of months ago in master but the fix needs to be cherry-picked into the 2.6 branch.
Comment 2 Mikayla Hutchinson [MSFT] 2011-08-18 11:02:57 UTC
*** Bug 200 has been marked as a duplicate of this bug. ***
Comment 3 Ken Budris 2011-08-18 11:09:04 UTC
This bug has something to do with the combination of MD and MT versions. Supposedly, MD 2.6 b2 works with the latest MT. But I found that MD 2.6 b3 worked ok with MT 4.0.3. I didn't see this bug until I upgraded to MT with MD 2.6 b3.
Comment 4 Mikayla Hutchinson [MSFT] 2011-08-18 11:14:19 UTC
It's MD that copies content files into the app bundle, mtouch has nothing to do with it.
Comment 5 Hipolyto 2011-08-18 16:02:15 UTC
is there any news for this?
Comment 6 Alex Soto 2011-08-19 13:01:11 UTC
Ok guys, I guess i found a workaround, please give this a try

Im running MD 2.6RC1, in order to your content files are being included in the final bundle, delete them from your project, then save your project close MD, then reopen MD and add again your content files to your project, don't forget to mark them as content ;)

this worked for me.

Comment 7 Ken Budris 2011-08-19 13:13:57 UTC
I tried Alex's workaround in MD 2.6RC1 but saw no difference in the Simulator or on the device.
Comment 8 Alex Soto 2011-08-19 13:15:47 UTC
mmm, I know that MonoDevelop its in charge on Bundling content files, but Ken what version of MonoTouch are you running? I'm on MonoTouch 4.9
Comment 9 Ken Budris 2011-08-19 13:30:55 UTC
I'm running MT I know Michael smacked me down for mentioning this before, but I'm quite certain the problem did NOT occur when I was running MD 2.6b3 w/MT 4.0.3, and only appeared once I upgraded to MT
Comment 10 Alex Corrado [MSFT] 2011-08-20 14:25:20 UTC
This is fixed in MD 2.6 RC2. From RC1, you should receive an update notification for RC2 on the beta channel.
Comment 11 Ken Budris 2011-08-24 08:33:11 UTC
I've confirmed that the problem is resolved when running MD 2.6 RC2 / MT 4.1.0 / Mono 2.10.4 / iOS 5 beta6 on Snow Leopard. Thanks.
Comment 12 Hipolyto 2011-08-24 10:28:54 UTC
Yes, wokrs fine MD 2.6 RC2