Bug 30872 - Profiler opens from menu but does not start profiling app
Summary: Profiler opens from menu but does not start profiling app
Alias: None
Product: Profiler
Classification: Xamarin
Component: General ()
Version: unspecified
Hardware: PC Windows
: Normal normal
Target Milestone: ---
Assignee: Dominique Louis
Depends on:
Reported: 2015-06-07 04:17 UTC by RJantz
Modified: 2015-07-17 05:17 UTC (History)
6 users (show)

Is this bug a regression?: ---
Last known good build:

profiler log (212 bytes, application/octet-stream)
2015-06-07 04:17 UTC, RJantz
Process explorer screenshot of profiler after running from Xamarin (178.56 KB, image/jpeg)
2015-06-08 21:21 UTC, RJantz
Screenshot of profiler running from Xamarin (67.93 KB, image/jpeg)
2015-06-08 21:22 UTC, RJantz
Current profiler log (212 bytes, application/octet-stream)
2015-06-09 10:27 UTC, RJantz
0.16 profiler logs and error screen (48.78 KB, application/zip)
2015-06-11 23:54 UTC, RJantz
Screenshot #1 No console tab in profiler and runtime error (76.58 KB, image/jpeg)
2015-06-23 01:30 UTC, RJantz
Screenshot #2 Console tab shows up only when connected to live profiling session (110.42 KB, image/jpeg)
2015-06-23 01:32 UTC, RJantz

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description RJantz 2015-06-07 04:17:17 UTC
Created attachment 11495 [details]
profiler log

Profiler version 0.15 consistently opens and goes through deploying the app on the emulator or physical device but does not start profiling even after clicking on the start profiling button or file menu. Debugging the app via emulator or physical device works as expected.
Comment 1 Dominique Louis 2015-06-08 15:04:19 UTC
Hi Orion,
  I'm not able to reproduce your scenario. 
Could you please confirm which version of Visual Studio or Xamarin Studio you are using on Windows?
Could you please also attach a screenshot of the Profiler after it launches.


Comment 2 Dominique Louis 2015-06-08 15:06:42 UTC
Also using the Process Explorer, as per this example, http://superuser.com/questions/415360/how-do-i-find-out-command-line-arguments-of-a-running-program, could you also confirm what parameters were used to start the Xamarin Profiler process.


Comment 3 RJantz 2015-06-08 21:21:02 UTC
Created attachment 11527 [details]
Process explorer screenshot of profiler after running from Xamarin
Comment 4 RJantz 2015-06-08 21:22:30 UTC
Created attachment 11528 [details]
Screenshot of profiler running from Xamarin
Comment 6 Dominique Louis 2015-06-09 08:29:03 UTC
Hi Orion,
  Is StartActivity the only activity marked as "MainLauncher = true"? 
Also the profiler.log you posted originally, can you confirm this was taken by going to "Help->Open Log Directory" inside the Profiler, then re-ordering the log files to most recent at the top, then that log file was the one attached?

Apologies if this is obvious, I just want to make sure everything is covered.

Comment 7 RJantz 2015-06-09 10:26:38 UTC
1. Yes, StartingActivity is the only activity marked MainLauncher = true.
2. Yes, that was the most current log at that point. To double check I opened the profiler again and went "Help->Open Log Directory" and attached the result.
Comment 8 RJantz 2015-06-09 10:27:52 UTC
Created attachment 11533 [details]
Current profiler log
Comment 10 Dominique Louis 2015-06-09 10:44:34 UTC
Hi Orion,
  Sure can you allow me to remote in?


Comment 13 Dominique Louis 2015-06-09 11:15:17 UTC
I'm around for the next 4 hours.

I have TeamViewer.
Comment 15 Dominique Louis 2015-06-09 11:40:12 UTC
I'm around from 10am GMT until 7-8pm GMT. most days.
Comment 17 Dominique Louis 2015-06-10 06:57:38 UTC
OK I'll be available at 7PDT today.
Comment 20 Dominique Louis 2015-06-11 12:53:40 UTC
Hi Orion,  
  Great news. I've just tested the latest Alpha release myself and Android profiling was fixed by the runtime team. You can grab it from the Alpha channel.

It should work with the latest 0.16 Profiler release. So you could try to switch to this latest Alpha, but keep in mind it is an Alpha of Android and iOS. I suggest being ready to roll-back to the latest Beta or Stable if you notice anything unusual happening in your app.

I will close this issue for now, but re-open it if profiling is still not working for you.

Comment 21 RJantz 2015-06-11 23:45:53 UTC
I got 0.16 to profile once on an emulator. I cannot get it to profile again on the same emulator or a physical device. If I need to start this as a separate bug report let me know. The profiler opens fine but crashes immediately upon opening.
I will attach a zip file of the successful and unsuccessful runs on 0.16.
Comment 22 RJantz 2015-06-11 23:54:56 UTC
Created attachment 11581 [details]
0.16 profiler logs and error screen
Comment 23 Dominique Louis 2015-06-12 12:10:56 UTC
@orion Is this error happening with the latest Alpha, or just with the latest 0.16 and a previous Beta/Stable?
Comment 24 RJantz 2015-06-12 13:31:30 UTC
With the latest alpha. I switched XS to the alpha channel and left it there.
Comment 25 Udham Singh 2015-06-12 13:58:39 UTC
I have checked this issue with latest Alpha Xamarin builds (XS + XVS 3.11.658) and Xamarin Profiler, is working fine for me. Please refer the screencast : http://www.screencast.com/t/YLcRlXc6iN38

@orion could you please check this with latest Alpha channel builds and let us know if you are still getting this issue.

Comment 27 Dominique Louis 2015-06-12 15:52:02 UTC
Hi Ryan,
  Can I organise another Team meeting session with you next week? Let me know which day works for you.


Comment 28 RJantz 2015-06-12 15:57:39 UTC
Does Monday @ 7:00am PDT work for you?
Comment 31 RJantz 2015-06-16 09:51:13 UTC
Are you in this morning or what day works for you?
Comment 32 Dominique Louis 2015-06-18 09:54:33 UTC
Sorry I've been ill Ryan. Will you be around tomorrow morning?
Comment 33 RJantz 2015-06-18 10:46:47 UTC
Yes. Tomorrow at 7:00 am PDT would work for me. Does that suit you?
Comment 34 Dominique Louis 2015-06-18 13:47:28 UTC
Yes that works Ryan.
Comment 35 Dominique Louis 2015-06-19 09:26:15 UTC
Ryan, let me know when you are ready.

Comment 37 Dominique Louis 2015-06-19 11:54:06 UTC
Hi Ryan,
  Tester confirm it works for them on Windows 7. They haven't installed Windows 10 yet, so can't confirm on there yet.

Are you logged into your machine as a used called "Office"?

Can you please confirm that the location "C:\Users\Office\AppData\Local\Temp\" exists on your HD?


Comment 39 Dominique Louis 2015-06-20 05:16:08 UTC
Hi Ryan,
  the last thing I can think of, is it might be the device. Can you borrow another Android device and try that?


Comment 40 Dominique Louis 2015-06-22 12:35:55 UTC
One of the other team members sending use the latest logcat.
I'd suggest clearing it first.
1. Clear logcat "adb logcat -c"
2. Pipe logcat to a file "adb logcat -d > logcat.txt"
3. try profiling on device.
4. Upon failure send us the logcat.

I'm not 100% convinced this will reveal anything new, but it is worth a try.

Comment 41 Rodrigo Moya 2015-06-22 14:37:57 UTC
Don't clear the log, the profiler already does that. Just profiling from the profiler, and when done, copy/paste the contents of the Console view in the profiler, which contains the logcat for the duration of the profile run
Comment 42 RJantz 2015-06-23 01:30:33 UTC
Created attachment 11709 [details]
Screenshot #1 No console tab in profiler and runtime error
Comment 43 RJantz 2015-06-23 01:32:14 UTC
Created attachment 11710 [details]
Screenshot #2 Console tab shows up only when connected to live profiling session

I tried a different device and the behavior was the same. Immediate crash and unable to get it to start by killing app and manually restarting the profiling from the triangle button.

The console tab in the profiler never was visible when I was trying to profile with any physical device.
Comment 44 Dominique Louis 2015-06-23 05:07:58 UTC
Hi Ryan,
  What is the contents of the Console Tab that that point? Is anything written to it?

Comment 45 RJantz 2015-06-23 10:31:22 UTC

When the app crashes on the physical device there is no console tab in the profiler.

Comment 46 RJantz 2015-07-17 00:11:15 UTC
As of profiler version 0.17 and the latest stable Xamarin Studio build I am able to profile on both emulator and physical device.

Comment 47 Udham Singh 2015-07-17 05:17:55 UTC
Thanks @Ryan for the confirmation.

As per comment 46, I am closing this issue.