Bug 30797 - list view header set to label on iOS
Summary: list view header set to label on iOS
Alias: None
Product: Forms
Classification: Xamarin
Component: iOS ()
Version: 1.4.2
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: ---
Assignee: Chris King
Depends on:
Reported: 2015-06-04 10:22 UTC by Alessandro
Modified: 2016-04-09 01:32 UTC (History)
5 users (show)

Tags: ac
Is this bug a regression?: ---
Last known good build:

project for bug (379.46 KB, application/zip)
2015-06-04 10:22 UTC, Alessandro

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description Alessandro 2015-06-04 10:22:24 UTC
Created attachment 11461 [details]
project for bug

I have a listview.
I try to set header to a label.
I have exceptions when I set it to an empty label.
tray SET and UNSET button

only on iOS
Comment 1 Alessandro 2015-06-04 10:27:49 UTC
Unable to cast object of type 'Xamarin.Forms.ListView' to type 'Xamarin.Forms.Label'.

this is the exception.
Sometimes it appears on "SET", sometime on "UNSET"
Comment 2 Chris King 2015-06-04 19:57:09 UTC
Thank you for taking the time to submit the bug. We tried to reproduce the issue you reported but were unable given the attached solution. 

Warm regards,
Xamarin Forms Team
Comment 3 Chris King 2015-06-04 20:08:57 UTC
Will try again. Another team member was able to repro.
Comment 4 Chris King 2015-06-05 19:25:55 UTC
See branch Bug30797x3
Comment 5 Alessandro 2015-06-06 15:57:32 UTC
Sorry Chris, I have not understand your last post. Have I to do something?
Comment 6 Jason Smith [MSFT] 2016-04-09 01:32:02 UTC
Thank you for taking the time to submit this report. After reviewing the description of this bug, we believe it no longer affects the current version of Xamarin.Forms. In particular the branch Chris mentioned should have fixed it and appears to be merged. If you are still experiencing the issue after updating your packages, please reopen this report with an attached reproduction.
For your convenience, we have created some reproduction best practices viewable here: https://gist.github.com/jassmith/92405c300e54a01dcc6d

Warm regards,
Xamarin Forms Team